Last Comment Bug 353716 - crash on quit [@ nsMacEventHandler::HandleMouseMoveEvent] or [@ nsMacEventHandler::ConvertOSEventToMouseEvent]
: crash on quit [@ nsMacEventHandler::HandleMouseMoveEvent] or [@ nsMacEventHan...
Status: RESOLVED FIXED
: crash, fixed1.8.1.4
Product: Core Graveyard
Classification: Graveyard
Component: Widget: Mac (show other bugs)
: Trunk
: x86 Mac OS X
: -- critical (vote)
: ---
Assigned To: Mark Mentovai
:
Mentors:
http://tinyurl.com/yukrtp
: 360047 372291 372959 376112 378586 382119 384170 (view as bug list)
Depends on:
Blocks: 344238 344570 368907 376012
  Show dependency treegraph
 
Reported: 2006-09-21 16:56 PDT by (not reading, please use seth@sspitzer.org instead)
Modified: 2011-06-09 14:58 PDT (History)
14 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
stack, from within gdb (2.88 KB, text/plain)
2006-09-21 16:57 PDT, (not reading, please use seth@sspitzer.org instead)
no flags Details
hit it again, but still not reproducable (29.70 KB, text/plain)
2006-09-22 17:54 PDT, (not reading, please use seth@sspitzer.org instead)
no flags Details
another crash log, similar (but different), in case this helps (32.00 KB, text/plain)
2006-09-23 15:41 PDT, (not reading, please use seth@sspitzer.org instead)
no flags Details
stack trace from user in #firefox (19.71 KB, text/plain)
2006-11-01 07:57 PST, Nick Thomas [:nthomas]
no flags Details
Fix (1.64 KB, patch)
2007-03-31 13:54 PDT, Mark Mentovai
jaas: review+
vladimir: superreview+
dveditz: approval1.8.1.4+
Details | Diff | Splinter Review

Description (not reading, please use seth@sspitzer.org instead) 2006-09-21 16:56:40 PDT
crash on quit [@nsMacEventHandler::HandleMouseMoveEvent]

this was with my debug, mac os x, trunk build

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a1) Gecko/20060921 Minefield/3.0a1

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x4a7400a2

0x158e9ff1 in nsMacEventHandler::HandleMouseMoveEvent (this=0x34128680, aOSEvent=@0xbfffee10) at /Users/sspitzer/Desktop/trunk/mozilla/widget/src/mac/nsMacEventHandler.cpp:1679
1679              lastWidgetPointed->GetBounds(bounds);
(gdb) print lastWidgetPointed
$1 = (nsWindow *) 0x20000
(gdb) where

I'll attach the full stack.

so far, I haven't been able to reproduce it.
Comment 1 (not reading, please use seth@sspitzer.org instead) 2006-09-21 16:57:07 PDT
Created attachment 239589 [details]
stack, from within gdb
Comment 2 Mark Mentovai 2006-09-21 18:16:15 PDT
Reproducible?
Comment 3 (not reading, please use seth@sspitzer.org instead) 2006-09-21 18:28:34 PDT
> Reproducible?

sorry mark, not yet.  :(
Comment 4 (not reading, please use seth@sspitzer.org instead) 2006-09-22 17:54:08 PDT
Created attachment 239746 [details]
hit it again, but still not reproducable
Comment 5 (not reading, please use seth@sspitzer.org instead) 2006-09-22 17:56:10 PDT
josh / mark, does that second crash report look like a different issue, or the the same as my stack attached as comment #1?  (The top of the stack looks similar).
Comment 6 (not reading, please use seth@sspitzer.org instead) 2006-09-23 15:41:02 PDT
Created attachment 239828 [details]
another crash log, similar (but different), in case this helps
Comment 7 Nick Thomas [:nthomas] 2006-11-01 07:57:51 PST
Created attachment 244314 [details]
stack trace from user in #firefox

A user (quix) reported this stack trace, which seems similar to the ones on this bug. This was with Firefox 2; he didn't know what the trigger was, but had been switching back to the app when it crashed.
Comment 8 Adam Guthrie 2006-11-08 21:59:56 PST
*** Bug 360047 has been marked as a duplicate of this bug. ***
Comment 9 Phil Ringnalda (:philor) 2007-03-01 15:45:30 PST
*** Bug 372291 has been marked as a duplicate of this bug. ***
Comment 10 Chris Dolan 2007-03-01 21:37:00 PST
Possibly related: bug 368907 which describes a nsMacEventHandler::HandleMouseMoveEvent crash on window close.
Comment 11 Phil Ringnalda (:philor) 2007-03-09 18:36:58 PST
*** Bug 372959 has been marked as a duplicate of this bug. ***
Comment 12 Samuel Sidler (old account; do not CC) 2007-03-20 16:13:36 PDT
This is a pretty popular crash on Mac with over 100 crashes thus far for Fx 2.0.0.2. Most of the comments in talkback indicate it's happening either when closing a window (as bug 368907 mentions) or on quit, most usually when doing a restart of Firefox for an extension install or update. Looking through a good portion of the crashes in the query below, I didn't see any on 10.3, but that could just be a consequence of most people on 10.4 by now. It's pretty universal across all minor releases of 10.4, however.

Talkback query: http://tinyurl.com/yukrtp
Comment 13 Mark Mentovai 2007-03-31 12:33:54 PDT
Fairly reliable testcase:

From a browser window, get the location bar autocomplete popup to show by starting to type something autocompletable (like "m") in the location bar.  With the popup displayed, begin moving the mouse cursor (within the window?).  With the popup displayed and the cursor moving, press command-W to close the window.
Comment 14 Mark Mentovai 2007-03-31 12:35:41 PDT
widget/src/mac/nsMacEventHandler.cpp:
1640   WindowRef wind = reinterpret_cast<WindowRef>(mTopLevelWidget->GetNativeData(NS_NATIVE_DISPLAY));
Comment 15 Mark Mentovai 2007-03-31 13:47:54 PDT
Caused by a conjunction of bug 344238 and bug 344570 (10.4-only after bug 345388).  A description is in the patch to follow.  The patch will fix this bug, and bug 368907.  I don't know about bug 376012.
Comment 16 Mark Mentovai 2007-03-31 13:54:31 PDT
Created attachment 260243 [details] [diff] [review]
Fix
Comment 17 Mark Mentovai 2007-04-02 12:34:57 PDT
Comment on attachment 260243 [details] [diff] [review]
Fix

1.8.1-only, this is a Mac topcrasher.
Comment 18 Daniel Veditz [:dveditz] 2007-04-04 11:00:14 PDT
Comment on attachment 260243 [details] [diff] [review]
Fix

approved for 1.8.1.4, a=dveditz for release-drivers
Comment 19 Mark Mentovai 2007-04-04 11:46:18 PDT
Checked in on MOZILLA_1_8_BRANCH.
Comment 20 Samuel Sidler (old account; do not CC) 2007-04-08 12:27:56 PDT
*** Bug 376112 has been marked as a duplicate of this bug. ***
Comment 21 Phil Ringnalda (:philor) 2007-04-24 07:33:58 PDT
*** Bug 378586 has been marked as a duplicate of this bug. ***
Comment 22 Adam Guthrie 2007-06-12 15:19:50 PDT
*** Bug 384170 has been marked as a duplicate of this bug. ***
Comment 23 Samuel Sidler (old account; do not CC) 2007-06-13 14:17:59 PDT
*** Bug 382119 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.