Closed Bug 376205 Opened 13 years ago Closed 13 years ago

Minefield crashes on startup [@ NS_strlen] (with textarea, myspell.dll)

Categories

(Firefox :: Installer, defect, critical)

x86
All
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: apuaongelmaan, Assigned: sipaq)

References

Details

(Keywords: crash, topcrash+)

Crash Data

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fi-FI; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2007-04-01-05-trunk/firefox-3.0a4pre.en-US.win32.installer.exe

When I start Minefield, it starts up, but Minefield crashes on startup immediately. It's the same with the earlier version, too.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield 3.0a4pre
2. Please, start Minefield and wait what's happening...
Actual Results:  
Minefield crash

Expected Results:  
Minefield start normally
Version: unspecified → Trunk
That build works for me on Windows XP SP2.

Some Questions:
1) Does Minefield crash if you try to start it in Safe Mode or with a new profile? http://kb.mozillazine.org/Safe_Mode
2) Can you provide a Talkback ID? http://kb.mozillazine.org/Talkback
3) Have you been able to run earlier versions of Minefield? If not, or you haven't tried, it might be bug 331404. Download the improved findold tool from that bug and run it to check for files with invalid dates. The discussion in this thread might help: http://forums.mozillazine.org/viewtopic.php?p=2816163#2816163

(In reply to comment #1)
> Some Questions:
> 1) Does Minefield crash if you try to start it in Safe Mode or with a new
> profile? http://kb.mozillazine.org/Safe_Mode
> 2) Can you provide a Talkback ID? http://kb.mozillazine.org/Talkback
> 3) Have you been able to run earlier versions of Minefield? If not, or you
> haven't tried, it might be bug 331404. Download the improved findold tool from
> that bug and run it to check for files with invalid dates. The discussion in
> this thread might help:
> http://forums.mozillazine.org/viewtopic.php?p=2816163#2816163
> 

1) Yes.
2) Yes, I can. Talkback ID is TB30795463W.
3) Yes, I have been able to run earlier versions of Minefield.
Stack from TB:
NS_strlen  [mozilla/xpcom/build/nscrtglue.cpp, line 102]
myspell.dll + 0x5594 (0x60055594)
myspell.dll + 0x5602 (0x60055602)
mozSpellChecker::GetDictionaryList  [mozilla/extensions/spellcheck/src/mozspellchecker.cpp, line 314]

According to Bug 376082 comment 17 that makes this a duplicate of that bug. But I don't understand why you are crashing at startup when I don't. But then I don't seem to be able to reproduce the bug at all. Try adding this line to the prefs.js file in your Minefield profile:

user_pref("layout.spellcheckDefault", 0);

If you still crash, please post a new Talkback ID

Lastly, I'm still a bit confused by you stating "It's the same with the earlier version, too." in comment 0 and then "Yes, I have been able to run earlier versions of Minefield." in comment 2.
Keywords: crash
Note that we have a NS_strlen crash over at Thunderbird too, Bug 376082
(In reply to comment #4)
> Note that we have a NS_strlen crash over at Thunderbird too, Bug 376082
> 

Yes, I'm trying to work out if this is a duplicate. It probably is. Also, I'm trying to find the conditions required and steps to reproduce the Firefox crash because I haven't seen it myself yet. What would be really good is an hourly regression range. Someone who experiences the Firefox crash could do that using the hourly archive at http://hourly-archive.localgho.st/ . Start halfway through the builds of the 27th and work backwards or forwards (jumping to halfway in between the last good and bad builds each step).

Right, I think I've found the cause of the crash. (Thanks to polidobj.) For a short while in July 2006 nightly builds shipped myspell.dll (At least the 2006071004 build did). When I put this dll in the components directory of a current trunk build I reproduce this crash. Doesn't happen with 2007032604. Presumably from bug 376082 comment 15 and 16 this started between 0327 and 0328. A regression window could still be interesting to determine which changed caused this, but nightly builds don't ship with myspell.dll.

I think this bug is invalid.

Last Question: those who experience this crash - where is the myspell.dll directory located (Program dir or Profile dir); what is the modified date on the file; and do you know where it came from?
Arie - You're a genius.  I removed myspell.dll and the myspell folder from the Program components directory and I no longer have a crash.  myspell.dll was dated 13/7/06 and the myspell directory 14/7/06, while the dictionary files in the myspell directory (en-GB.aff and en-GB.dic came from December 2002).


I should have said that I only tested this on Thunderbird - I don't have a working copy of Minefield - whenever I've installed it I've had problems and reverted to the ordinary Firefox.
I have been using Minefield trunk nightlies, and can confirm that removing myspell.dll from my minefield/components directory fixed this crash for me.  Just for the record, I was never crashing on startup unless I had a session saved that included a textarea.

Should automatic updates have deleted the myspell dll?  Is there a mozilla-side fix, or just word-of-mouth "deleted myspell.dll" since only long-time nightly testers are affected?
Regression range:
20070327_0832 Works
20070327_0944 Crash

checkins: http://tinyurl.com/285dea

I don't really see what caused this, but I'm pretty sure the myspell.dll shouldn't be coming back (spellcheck.lib is linked into firefox.lib instead). I asked for confirmation on mozilla.dev.apps.firefox .
Summary: Minefield crashes on startup → Minefield crashes on startup [@ NS_strlen] (with textarea, myspell.dll)
Status: UNCONFIRMED → NEW
Component: General → Installer
Ever confirmed: true
OS: Windows XP → All
QA Contact: general → installer
Attached patch Patch v1Splinter Review
Patch for both Firefox and Thunderbird on trunk.

Ben, do I need an additional review from mscott or bienvenu on the mozilla/mail changes?
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #260757 - Flags: review?(benjamin)
On Thunderbird I also had a sub-folder called myspell dated 14/7/06 in the components folder.  This contained en-GB.aff and en-GB.dic, which were created December 2002.
(In reply to comment #3)
> I don't understand why you are crashing at startup when I don't. But then I
> don't seem to be able to reproduce the bug at all. Try adding this line to the
> prefs.js file in your Minefield profile:
> 
> user_pref("layout.spellcheckDefault", 0);
> 
> If you still crash, please post a new Talkback ID
> 
When I added that line you advised, after that it seems to work.
(In reply to comment #3)
> Lastly, I'm still a bit confused by you stating "It's the same with the earlier
> version, too." in comment 0 and then "Yes, I have been able to run earlier
> versions of Minefield." in comment 2.
> 
I meant the versions released some days ago in the comment 0. In the comment 2 I meant e.g. the version Minefield 3.0a3pre.
Attachment #260757 - Flags: review?(benjamin) → review+
This is the #1 topcrash on both Firefox and Thunderbird trunk. Can we get this landed?
Blocks: 376082
Keywords: topcrash+
Comment on attachment 260757 [details] [diff] [review]
Patch v1

Scott, can I get your module owner approval (moa) for the mozilla/mail changes in this patch.

Benjamin Smedberg already reviewed this patch.
Attachment #260757 - Flags: review?(mscott)
Comment on attachment 260757 [details] [diff] [review]
Patch v1

sorry for the delay, I'm on vacation the last couple days.
Attachment #260757 - Flags: review?(mscott) → review+
Whiteboard: [checkin needed]
Checking in browser/installer/removed-files.in;
/cvsroot/mozilla/browser/installer/removed-files.in,v  <--  removed-files.in
new revision: 1.19; previous revision: 1.18
done
Checking in browser/installer/unix/packages-static;
/cvsroot/mozilla/browser/installer/unix/packages-static,v  <--  packages-static
new revision: 1.93; previous revision: 1.92
done
Checking in browser/installer/windows/packages-static;
/cvsroot/mozilla/browser/installer/windows/packages-static,v  <--  packages-static
new revision: 1.104; previous revision: 1.103
done
Checking in mail/installer/removed-files.in;
/cvsroot/mozilla/mail/installer/removed-files.in,v  <--  removed-files.in
new revision: 1.26; previous revision: 1.25
done
Checking in mail/installer/windows/packages-static;
/cvsroot/mozilla/mail/installer/windows/packages-static,v  <--  packages-static
new revision: 1.45; previous revision: 1.44
done
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Hmm, you removed spellchecker.xpt from mail's packages-static, but didn't put it into mail's removed-files.in like you did in browser's removed-files.in!?
Oh, I guess we don't ship linux installers since Firefox 1.0.x anymore.
Depends on: 377662
Crash Signature: [@ NS_strlen]
You need to log in before you can comment on or make changes to this bug.