Last Comment Bug 376255 - l10n CVS Account Request: Spanish/Spain (es-ES) - Guillermo López
: l10n CVS Account Request: Spanish/Spain (es-ES) - Guillermo López
Status: RESOLVED FIXED
voucher, ssh-key, form
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Jeremy Orem [:oremj]
: Dave Miller [:justdave] (justdave@bugzilla.org)
Mentors:
http://wiki.mozilla.org/L10n:Localiza...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-02 09:52 PDT by Guillermo López :willyaranda (probably SLOW response)
Modified: 2007-04-11 19:27 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
SSH Public Key - Guillermo López (612 bytes, text/plain)
2007-04-02 10:00 PDT, Guillermo López :willyaranda (probably SLOW response)
no flags Details

Description Guillermo López :willyaranda (probably SLOW response) 2007-04-02 09:52:11 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061115 Mandriva/2.0.0.1-4mdv2007.0 (2007.0) Firefox/2.0.0.1
Build Identifier: 

Hi, I'm the new owner of Firefox (es-ES). Actually Ricardo Palomares is one of the two commiters in our team, but Andrés is going to leave the browser module, so I'll continue his work.

Firefox translation (trunk es-ES) is up to date because Ricardo committed my work.

He will continue as the owner of the toolkit/seamonkey/thunderbird. 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Guillermo López :willyaranda (probably SLOW response) 2007-04-02 10:00:53 PDT
Created attachment 260353 [details]
SSH Public Key -  Guillermo López

Added my SSH key.
Comment 2 [:rickiees] Ricardo Palomares 2007-04-02 10:05:57 PDT
(In reply to comment #0)
> Hi, I'm the new owner of Firefox (es-ES). Actually Ricardo Palomares is one of
> the two commiters in our team, but Andrés is going to leave the browser
> module, so I'll continue his work.
> 
> Firefox translation (trunk es-ES) is up to date because Ricardo committed my
> work.
> 
> He will continue as the owner of the toolkit/seamonkey/thunderbird. 


I confirm this request and vouch for him. We will comment about this bug in m.d.l10n before updating 

http://wiki.mozilla.org/L10n:Teams:es-ES

and

http://wiki.mozilla.org/L10n:Localization_Teams#Spanish.2C_Spain_.28es-ES.29

> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
> 

Comment 3 Marcia Knous [:marcia - use ni] 2007-04-02 13:14:13 PDT
need the hacking form returned via email or fax->www.mozilla.org/hacking.form.html.
Comment 4 Guillermo López :willyaranda (probably SLOW response) 2007-04-02 13:18:06 PDT
(In reply to comment #3)
> need the hacking form returned via email or
> fax->www.mozilla.org/hacking.form.html.
> 

Hi! Can I send the form to your email, instead sending it by fax? [marcia at mozilla.org]

Regards
Comment 5 Marcia Knous [:marcia - use ni] 2007-04-02 13:24:44 PDT
email works fine and is encouraged. -> send to [marcia at
mozilla.org].

(In reply to comment #4)
> (In reply to comment #3)
> > need the hacking form returned via email or
> > fax->www.mozilla.org/hacking.form.html.
> > 
> 
> Hi! Can I send the form to your email, instead sending it by fax? [marcia at
> mozilla.org]
> 
> Regards
> 

Comment 6 Guillermo López :willyaranda (probably SLOW response) 2007-04-02 13:52:52 PDT
Well,(In reply to comment #5)
> email works fine and is encouraged. -> send to [marcia at
> mozilla.org].
>

But, a scan of the printed form should work, isn't it?

Because I don't know other system :S

Regards

Comment 7 Guillermo López :willyaranda (probably SLOW response) 2007-04-03 17:40:20 PDT
Email sent to Marcia, I'm waiting the confirmation...
Comment 8 Marcia Knous [:marcia - use ni] 2007-04-04 09:47:37 PDT
I have received the form sent via email. I will await Axel's OK to move forward with the account.

(In reply to comment #7)
> Email sent to Marcia, I'm waiting the confirmation...
> 

Comment 9 Axel Hecht [:Pike] 2007-04-04 10:03:37 PDT
Vouching, this is OK for me.

Guillermo, Ricardo, please update the wiki pages, too?

You would want to read http://groups.google.com/group/mozilla.governance/browse_frm/thread/e6257f5637d5e135/af628cd4d266896a#af628cd4d266896a, too, as Ricardo and I count as vouchers for Guillermo. As I said in that thread, not everything applies word by word, but the global message stays. Guillermo, if you need advice on the current process and status, make sure to check in with Ricardo and me before touching the cvs repository, in particular when checking in on branches.
Comment 10 Marcia Knous [:marcia - use ni] 2007-04-04 10:09:06 PDT
per Axel's comment, over to server-ops for Account Creation.
Comment 11 [:rickiees] Ricardo Palomares 2007-04-04 14:16:43 PDT
(In reply to comment #9)
> Vouching, this is OK for me.
> 
> Guillermo, Ricardo, please update the wiki pages, too?
>

Sorry, I replied in the newsgroup to Guillermo's post, but I forgot to kick it out of my PC. :-/

OK, I've changed wiki pages.

> You would want to read
> http://groups.google.com/group/mozilla.governance/browse_frm/thread/e6257f5637d5e135/af628cd4d266896a#af628cd4d266896a,
> too, as Ricardo and I count as vouchers for Guillermo. As I said in that
> thread, not everything applies word by word, but the global message stays.


Read. Guillermo, what we'll do once you get CVS account is this:

- Instead of directly committing, you will running cvs -z3 diff -u on your local l10n copy, and will handle the patch to me.

- I'll review it and reply you giving you OK and exact instructions on how to commit changes.

The first bunch of commits will be run this way, since we're going to work in trunk (I'll care about MOZILLA_1_8_BRANCH in case any change is needed) and we're not in a hurry in trunk anyway, so we can allow the delay caused by this procedure for a while.


> Guillermo, if you need advice on the current process and status, make sure to
> check in with Ricardo and me before touching the cvs repository, in particular
> when checking in on branches.


Axel, I hope my above plan sounds careful enough. If you think there is room for improvement, don't hesitate to comment.

Thank you.
Comment 12 Axel Hecht [:Pike] 2007-04-04 15:25:50 PDT
Ricardo, sounds great, thanks.
Comment 13 matthew zeier [:mrz] 2007-04-06 10:51:14 PDT
Sorry for the delay on this,

Your CVS account has been created.  Your CVSROOT should be:

   willyaranda%gmail.com@cvs.mozilla.org:/l10n

Don't forget to set your CVS_RSH environment variable to 'ssh'.

If you have any problems connecting, let me know.
Comment 14 Guillermo López :willyaranda (probably SLOW response) 2007-04-07 06:10:17 PDT
Ok, thanks for the account.

Well, I haven't send the mail (by letter) because in Spain we have holidays, but this Monday I'll send it.

Regards
Comment 15 Guillermo López :willyaranda (probably SLOW response) 2007-04-08 09:41:24 PDT
@matthew zeier

Hi. I have some problems to download a copy of the es-ES repository... (to connect to the repository with my account, which gives this error: Permission denied (publickey,gssapi-with-mic).

Ricardo helped me but nothing works. We try to set up the CVS_RSH to ssh, but no works, to edit manually some files, no work. I tried a command that Axel told Ricardo some time ago (cvs -z3 -d willyaranda%gmail.com@cvs.mozilla.org:/l10n co l10n/es-ES) but no works.

We don't know what's happening (Ricardo, because he knows, but me...), so I one of Mozilla developers could help me...

Regards, and sorry for that!
Comment 16 [:rickiees] Ricardo Palomares 2007-04-08 10:36:04 PDT
(In reply to comment #15)
> Hi. I have some problems to download a copy of the es-ES repository... (to
> connect to the repository with my account, which gives this error: Permission
> denied (publickey,gssapi-with-mic).

To expand on what we have tried to do and the setup, this is our checklist:

- Guillermo uses a .ssh/config file with this content:

Host *.mozilla.org
    IdentitiesOnly yes
    IdentityFile ~/.ssh/id_mozilla

- We have checked that .ssh/config has 600 permissions as ssh docs says. Its .ssh/id_mozilla private key file also has 600, while .ssh/id_mozilla.pub has 644. I have the same permissions and SSH config and it works for me (if Axel reads this, I had a similar problem because I named the file ssh_config instead of just config; this is not the case now). :-)

- We have tried to run:

cvs -z3 -d willyaranda%gmail.com@cvs.mozilla.org:/l10n co l10n/es-ES

manually (instead of any automated script, to discard any other possible factor), and he has keep getting the same error.

So, we are a bit stuck. I will keep monitoring this to help Guillermo with any further indication you give him. Sorry for the annoyances.
Comment 17 Jeremy Orem [:oremj] 2007-04-11 19:27:49 PDT
The key looked truncated.  Please try now.

Note You need to log in before you can comment on or make changes to this bug.