MozillaBuild does not detect VC8 via registry key on Win2k

RESOLVED WONTFIX

Status

--
major
RESOLVED WONTFIX
12 years ago
10 years ago

People

(Reporter: mcsmurf, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
I'm running Win2k SP4. MozillaBuild does not find the VC8 product key under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VCExpress\8.0\Setup\VC\ProductDir because Win2k does not ship with reg.exe. Maybe it is possible to ship reg.exe with MozillaBuild (license issues?), if not maybe there is a registry reading workaround for Win2k...

Comment 1

12 years ago
reg.exe is contained in the windows 2000 support tools, which should come with your install CD.

http://support.microsoft.com/kb/301423

Comment 2

12 years ago
None of the VC compilers, nor the Platform SDK, are detected by registry key because reg.exe isn't native to W2K.  Suggest changing the bug summary.

A newbie developer using W2K has to hunt and peck for a varying number of hours to determine why the build doesn't work.  This is an unpleasant introduction to MozillaBuild.

Solutions: (1) ship a reg.exe as suggested above, (2) test for the availability of reg.exe, warn the user if it's missing, and provide instructions for how to obtain it, (3) at least document the requirement on the build instructions webpage, so that the newbie knows there's something they have to do.

Comment 3

12 years ago
Patches accepted. I don't think we can legally distribute reg.exe, so options 2) or 3) are best.

Comment 4

12 years ago
Installing the support tools also isn't quite sufficient, as by default,
guess-msvc.bat will wipe out the PATH needed to find reg.exe.  After
installation teh support tools live at "%ProgramFiles%\Support Tools" .
Mass re-assign of MozillaBuild bugs into mozilla.org:MozillaBuild
Component: Build Config → MozillaBuild
Product: Core → mozilla.org
Version: Trunk → other
QA Contact: build-config → mozillabuild
Don't care enough about Win2k. Sorry.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 488654
You need to log in before you can comment on or make changes to this bug.