Session Management: Toc view column ordering not remembered between launches

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: mdudziak, Assigned: beckley)

Tracking

Details

(Reporter)

Description

12 years ago
The problem is that, when the Penelope extension is installed, the ordering of the TOC view columns is not remembered. For example, if I move the 'Junk' column to the far right, then quit/restart, the Junk column is back to where it was before the restart. If NOT using the Penelope extension, I can move the Junk column to the far right, then restart Thunderbird and the Junk column remains at the far right. Enabling the Penelope extension again at this point causes the Junk column to move back to where it always is in Penelope.

To reproduce:
- With Penelope extension enabled:
- View your Inbox
- Drag the "junk' column header to the far right.
- Quit/restart Thunderbird with Penelope extension enabled
- Note that the Junk column is no longer on the far right, but has moved back to prior location.
- Disable Penelope extension
- Quit/restart (now is Thunderbird without Penelope extension)
- Repeat above (drag Junk column to far right, quit/restart)
- Note now that the Junk column REMAINS at the far right, as expected.

Problem only present for me when Penelope extension is enabled.
(Reporter)

Updated

12 years ago
Target Milestone: 0.1 → 0.5

Comment 1

12 years ago
this error continues in thunderbird 2, penelope 1a19

Comment 2

11 years ago
Additionally it would be nice if the order of the columns could be different per mailbox.  For example the drafts mailbox does not need a junk column, and I can imagine other mailboxes needing various fields and their placement and width being different from other mailboxes.
(Reporter)

Updated

11 years ago
Assignee: mcharleb → mozilla-bugs
Status: ASSIGNED → NEW

Comment 3

11 years ago
For me, if I set the column order, it does not even persist the next time I open the window.  (I do not have to even quit).

(Reporter)

Updated

11 years ago
Priority: -- → P5
(Reporter)

Updated

11 years ago
Assignee: mozilla-bugs → beckley
Summary: Toc view column ordering not remembered between launches → Session Management: Toc view column ordering not remembered between launches
(Reporter)

Updated

11 years ago
Priority: P5 → P2
(Reporter)

Updated

11 years ago
Status: NEW → ASSIGNED
this bug is still outstanding as of beta 8.0.0b3, TB 2.0.0.14. the associated bug is that if you configure what columns to show/not show, the change is not persistent after restarting TB/eudora. disable eudora, set columns as you like, they remain as you like persistently. enable eudora, and they revert back to defaults.
correction, i'm running penelope 0.1a19, the add-on, as opposed to having simply installed the 8.0.0b3 from installer. not that it likely makes any difference.

Comment 6

10 years ago
this occurs in eudora 800b4, linux
(Assignee)

Comment 7

10 years ago
For those with initiative, this bug is fixed in the Penelope hg source code
depot: <http://hg.mozilla.org/penelope/rev/df2d83297f88>.

Otherwise you'll have to wait until the next release, Eudora 8 beta 7/Penelope
0.5a4.
(Reporter)

Comment 8

9 years ago
Fixed in Eudora 8.0b7
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Duplicate of this bug: 394958
(Reporter)

Updated

9 years ago
Target Milestone: 0.5 → ---
You need to log in before you can comment on or make changes to this bug.