Closed Bug 376690 Opened 14 years ago Closed 11 years ago

[regression] square list marker has incorrect size

Categories

(Core :: Layout: Block and Inline, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla1.9.3a2

People

(Reporter: phiw2, Assigned: dbaron)

References

()

Details

(Keywords: regression, testcase)

Attachments

(5 files, 1 obsolete file)

Attached file test case
ul {list-style:square; font-size: .9em;}
This result in a list-marker that is sometimes square, sometimes smashed or stretched vertically

regressed between 20070206-11 and 20060207-02 --> bug 177805
Attached image screen shot
Blocks: pixels
Hmm, looks like a pixel snapping bug; I can't reproduce it on Windows, though...
Confirming on Windows XP using the Minefield nightly from yesterday. Link to screenshot...
http://forums.mozillazine.org/viewtopic.php?p=2839746#2839746
Flags: blocking1.9?
Flags: blocking1.9? → blocking1.9-
This is much better in some cases since the landing of bug 96041. When the line-height is set to normal (as is the testcase), the list-marker now displays correctly. 
But change the line-height (say, something like 1.5), the list-maker takes all kind of shapes, none looking like a square.
Attached file test case 2
Same test case as the first one, but with line-height:1.5 specified
Flags: wanted1.9.1?
Flags: wanted1.9.0.x?
Duplicate of this bug: 442082
From dupe: This can clearly be seen on the about:robots page.
We could fix this by snapping the size of the squares to the nearest pixel before drawing.  If we do this, we should center within the original non-snapped size, though.

(Note that for counters we use glyphs, though, so this wouldn't apply there.)
Flags: wanted1.9.1? → wanted1.9.1+
Attached file testcase 3 (obsolete) —
This fails on winXP, testcase 2 does not
OS: Mac OS X → All
Hardware: Macintosh → All
Attached file testcase 3 (Windows)
Attachment #330432 - Attachment is obsolete: true
Flags: wanted1.9.0.x? → wanted1.9.0.x+
still here on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090420 Minefield/3.6a1pre (.NET CLR 3.5.30729) ID:20090420041629
Flags: wanted1.9.2? → wanted1.9.2+
Attached patch patchSplinter Review
This came up on css-d today; it's pretty simple to fix.

I figure centering is probably the best option, although I'm really not sure that it's the most likely to match what we're doing to text.
Assignee: nobody → dbaron
Status: NEW → ASSIGNED
Attachment #426173 - Flags: review?(roc)
Comment on attachment 426173 [details] [diff] [review]
patch

this probably wouldn't be hard to reftest
Attachment #426173 - Flags: review?(roc) → review+
Duplicate of this bug: 546041
http://hg.mozilla.org/mozilla-central/rev/7b1c9ad46a36
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a2
Priority: -- → P3
verified fixed with
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a2pre) Gecko/20100220 Minefield/3.7a2pre
@ rev/777fac9d915c
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.