Add Bookmark/Folder dialog start with zero height

RESOLVED DUPLICATE of bug 375629

Status

()

RESOLVED DUPLICATE of bug 375629
12 years ago
9 years ago

People

(Reporter: tabmix.onemen, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070407 Minefield/3.0a4pre
Build Identifier: 

Add Bookmark / Folder start with zero height after folder that was in the 
List of recently used folders was deleted.

Reproducible: Always

Steps to Reproduce:
1. on new profile add new folder.
2. from firefox window call Bookmark This Page...
3. the Add Bookmaek dialog opened as expected.
4. from the dialog expand the bookmarks tree 
5. add bookmark to the new folder (close the dialog with OK).
6. delete the new folder
7. from firefox window call Bookmark This Page... (again)

Actual Results:  
Add Bookmark start with zero height

in the error console we get this error:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsINavBookmarksService.getFolderTitle]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://browser/content/places/bookmarkProperties.js :: BPP__appendFolderItemToMenuList :: line 374"  data: no]

Expected Results:  
dialog open in with height fit to content.
(Reporter)

Comment 1

12 years ago
when add bookmark or add folder create new item the parent folder get 
new annotation "bookmarkPropertiesDialog/lastUsed"

this annotation is not remove when the folder remove.
(Reporter)

Updated

12 years ago
Summary: Add Bookmark / Folder start with zero height → Add Bookmark/Folder dialog start with zero height
Can you only reproduce this with Places? I can't reproduce this using a standard trunk nightly.
(Reporter)

Comment 3

12 years ago
only with Places
Version: unspecified → Trunk
(Reporter)

Updated

12 years ago
Duplicate of this bug: 379731
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 375629
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.