[RFE] automatic http:// in bugzilla URL field

VERIFIED FIXED in Bugzilla 2.12

Status

()

P3
enhancement
VERIFIED FIXED
19 years ago
6 years ago

People

(Reporter: jruderman, Assigned: Chris.Yeh)

Tracking

unspecified
Bugzilla 2.12
Other
Other

Details

(Whiteboard: 2.12, URL)

(Reporter)

Description

19 years ago
users often forget to include http:// in urls when submitting bugs.  i suggest 
that if a url doesn't have a protocol that http:// be added automatically.

alternatively, the new bug page could be modified to say "(include http://!)" 
right after the url field, but last i heard the goal was to not clutter the new 
bug page.

Comment 1

19 years ago
Yes, this is a common mistake by first-time bug report filers.
Without the protocol specified, the _URL_ link on show_bug.cgi pages
ends up pointing to http://bugzilla.mozilla.org/www.somedomain.sometld/whatever
-- which is an annoyance. 

Silently fixing these is probably the best approach, but "http://" should
not be automatically prepended if the URL starts with "ftp." or "mail." --
although, at that, there would be far fewer of those to fix up than we have
now for URLs with no protocol specified.

Comment 2

19 years ago
Yo, we got a patch for this.

Comment 3

19 years ago
*** Bug 39104 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
There's a dueling proposal in bug 42609, "Only allow well formed URLs in URL 
field of bug report"... this RFE and that one can't both be applied.

Comment 5

19 years ago
that's only sort-of true.
fixing this doesn't keep people from entering well-formed URLs,
infact, this won't touch correct entries.
(Assignee)

Comment 6

18 years ago
consideration for 2.12
Assignee: tara → cyeh
Whiteboard: 2.12
(Assignee)

Comment 7

18 years ago
see bug 42609 for what eventually happened to this bug.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
Sorry for the spam, but I needed to be able to query for all of these correctly.
Target Milestone: --- → Bugzilla 2.12

Comment 9

18 years ago
Y.
Status: RESOLVED → VERIFIED
Moving closed bugs to Bugzilla product
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: other → unspecified
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.