bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

scrub comment and summary for email addresses




Creating/Changing Bugs
11 years ago
3 years ago


(Reporter: Dan Holmes, Unassigned)





11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20070312 Firefox/
Build Identifier:  Bugzilla  Version 2.22  

When entering comments sometimes the comments are copied from an email client.  If that email is threaded the actual email addresses of the people involved in the email are included in the text.

It would be great if part of the submission of the comment would scrub the email addresses.  That could mean anything from removing the email to changing the address to something that doesn't get converting to a link when viewed.

Reproducible: Always

Steps to Reproduce:
1.  create bug
2.  Paste this from email.

From: Dan Holmes [mailto:DHolmes@somewhere.com] 
Sent: Monday, March 26, 2007 5:30 PM
To: Bryant Whitsitt
Subject: RE: lunch or something soon
How are you for this week?  Wednesday and Thursday evening or any lunch except Friday are ok for me.

From: Br Someone [mailto:brsomeone@someone.com] 
Sent: Tuesday, March 20, 2007 8:37 AM
To: Dan Holmes
Subject: RE: lunch or something soon

Hey Dan - thanks - maybe lets get something on the calendar for a week or two out. 

3.  submit bug

Expected Results:  
the email is removed or replaced with guy at somewhere dot com

Comment 1

11 years ago
in version 3 i guess bug comments can be added to bug via email.  I would want the email addresses to be scubbed there too.

What i would probably do when using that feature is cc/bcc bugzilla so the email is collected as a comment.

Comment 2

11 years ago
We already do it, see bug 120030.
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 120030

Comment 3

11 years ago
(In reply to comment #2)
> We already do it, see bug 120030.
> *** This bug has been marked as a duplicate of bug 120030 ***

Well not technically.  This particular issue is dependent on a side effect of the way bug 316826 is fixed.  I am using the comments on bug 120030 comment #157.

Plus as you can see from comment #0 of this bug clearly email addresses can still be put in comments.

Comment 4

11 years ago
Hum, you are right. The obfuscation only occurs if you use FILTER html, but we use FILTER quoteUrls for comments. Note that we will most likely never prevent email addresses from appearing in comments, if that's what you expected.
Severity: enhancement → minor
Depends on: 316826
OS: Windows XP → All
Hardware: PC → All
Resolution: DUPLICATE → ---

Comment 5

8 years ago
For consistency with what we do since Bugzilla 3.4, I think we should replace "@" by " at " and "." by " dot " only for logged out users. Logged in users can already see most email addresses already.
Severity: minor → enhancement
Ever confirmed: true
Version: unspecified → 2.22


8 years ago
No longer depends on: 316826
I think this bug should be WONTFIXed. A regexp which detects email addresses in free text will have false positives. It will also change things in bug reports which might be very relevant to the report - e.g. some mail headers in a Thunderbird report - in a way which will confuse people reading the bug. They would need to work out what had happened and mentally de-obfuscate the text.

You need to log in before you can comment on or make changes to this bug.