If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

posinset and setsize incorrect for lists with poor markup

RESOLVED FIXED

Status

()

Core
Disability Access APIs
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Scott Haeger, Assigned: surkov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a4pre) Gecko/20070409 Minefield/3.0a4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a4pre) Gecko/20070409 Minefield/3.0a4pre

posinset and setsize should match what is rendered to the page even for pages that have incorrect markup.

Reproducible: Always
(Reporter)

Comment 1

11 years ago
Created attachment 261045 [details]
test case 1

Test case shows a list of 9 items, only 7 of which get rendered due to bad markup.  posinset and setsize should match the number and position that are rendered
(Reporter)

Updated

11 years ago
Blocks: 374115

Updated

11 years ago
No longer blocks: 374115
(Assignee)

Comment 2

11 years ago
Created attachment 261098 [details] [diff] [review]
patch
Assignee: aaronleventhal → surkov.alexander
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #261098 - Flags: review?(aaronleventhal)

Updated

11 years ago
Attachment #261098 - Flags: review?(aaronleventhal) → review+
(Assignee)

Comment 3

11 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.