Additional "ghost" accessibles are being created

RESOLVED INVALID

Status

()

Core
Disability Access APIs
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Scott Haeger, Assigned: Aaron Leventhal)

Tracking

(Blocks: 1 bug)

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a4pre) Gecko/20070409 Minefield/3.0a4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a4pre) Gecko/20070409 Minefield/3.0a4pre

Additional "ghost" accessibles are being created.  These accessibles have no name or role.  See attached test page and inspect with accerciser.

Reproducible: Always
(Reporter)

Updated

11 years ago
Blocks: 374115
(Reporter)

Comment 1

11 years ago
Created attachment 261047 [details]
test case 1 to illustrate "ghost" accessible
(Reporter)

Comment 2

11 years ago
The last accessible under document frame for the test case is a "ghost" accessible.  It's path is 0,3,0,2,0,0,10.  The children of the first paragraph with children are also ghost accessibles.
(Assignee)

Updated

11 years ago
Blocks: 368880
(Assignee)

Comment 3

11 years ago
* There is no text because those objects have no text -- it's how web authors code anchors, e.g. <a></a>
* There is no role because role of link isn't working for accerciser or the infrastructure

Suggest INVALID.
(Assignee)

Comment 4

11 years ago
Closing after IRC discussion.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.