Last Comment Bug 376952 - pointer-events not registered for elements using a clipPath with no fill
: pointer-events not registered for elements using a clipPath with no fill
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: General SVG Bugs
: Hixie (not reading bugmail)
Mentors:
http://svg-whiz.com/svg/bugs/ff2/clip...
: 380053 406624 (view as bug list)
Depends on:
Blocks: 407299
  Show dependency treegraph
 
Reported: 2007-04-09 15:23 PDT by Doug Schepers
Modified: 2007-12-06 22:52 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
minimal test case (1.20 KB, image/svg+xml)
2007-04-09 15:25 PDT, Doug Schepers
no flags Details
ignore pointer-events and early exit for clipPath children (1.81 KB, patch)
2007-04-09 15:57 PDT, tor
longsonr: review+
roc: superreview+
Details | Diff | Review
update to tip (1.92 KB, patch)
2007-12-03 13:23 PST, tor
longsonr: review+
roc: superreview+
tor: approval1.9+
Details | Diff | Review

Description Doug Schepers 2007-04-09 15:23:17 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Elements using clip-path should still receive pointer events.  If the element that they are clipping to (in the 'clipPath') has fill="none", then the pointer events do not seem to register on the clipped element.

Reproducible: Always

Steps to Reproduce:
1. In test file, click on the rectangles and circles 
2. an alert box identifying the clicked element should appear
3. 
Actual Results:  
rightmost circle, referencing the rect with no fill, does not fire an event

Expected Results:  
rightmost circle should fire an event

you might look at properties such as stroke, and also at style properties vs. presentation attributes
Comment 1 Doug Schepers 2007-04-09 15:25:00 PDT
Created attachment 261068 [details]
minimal test case
Comment 2 tor 2007-04-09 15:57:30 PDT
Created attachment 261071 [details] [diff] [review]
ignore pointer-events and early exit for clipPath children
Comment 3 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2007-04-18 14:27:17 PDT
Comment on attachment 261071 [details] [diff] [review]
ignore pointer-events and early exit for clipPath children

+  // check if we're a clipPath - cheaper than IsClipChild(), and we shouldn't
+  // get in here for other nondisplay children

This sounds fragile. Can you at least assert that it's really a clippath?
Comment 4 JP Fiset 2007-05-08 08:20:07 PDT
Please, consider bug 380053
Comment 5 Jonathan Watt [:jwatt] 2007-11-26 15:28:12 PST
What happened here?
Comment 6 tor 2007-12-03 13:07:15 PST
*** Bug 406624 has been marked as a duplicate of this bug. ***
Comment 7 tor 2007-12-03 13:12:47 PST
*** Bug 380053 has been marked as a duplicate of this bug. ***
Comment 8 tor 2007-12-03 13:14:11 PST
(In reply to comment #5)
> What happened here?

Forgot to check in when it got reviews, then lost in the mists of time.
Comment 9 tor 2007-12-03 13:23:37 PST
Created attachment 291286 [details] [diff] [review]
update to tip
Comment 10 tor 2007-12-03 21:12:01 PST
Checked in.
Comment 11 jonathan chetwynd 2007-12-06 22:25:05 PST
I'd like to reopen this bug for mac os x as this is broken
Comment 12 Samuel Sidler (old account; do not CC) 2007-12-06 22:33:30 PST
Jonathan, can you please file a new bug for the brokenness on Mac OS X and mark it as a dependency of this bug?
Comment 13 jonathan chetwynd 2007-12-06 22:50:29 PST
#11 files a separate bug:
Bug 407299 

Note You need to log in before you can comment on or make changes to this bug.