pointer-events not triggered on clipped elements

RESOLVED DUPLICATE of bug 376952

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 376952
11 years ago
11 years ago

People

(Reporter: JP Fiset, Unassigned)

Tracking

({regression, testcase})

Trunk
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a4) Gecko/20070427 GranParadiso/3.0a4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a4) Gecko/20070427 GranParadiso/3.0a4

Clipped elements do not receive pointer events in Grand Paradiso 4. This is higly related to bug 376952, however there is no work around. If the mouse event is registered with the element as opposed to the associated clip path, then events are never fired.

Reproducible: Always

Steps to Reproduce:
1. Create a clipped element
2. Associate "mouseover" event with clipped element
3. Once rendered, mouse over the clipped element
Actual Results:  
Mousing over the clipped element fails to trigger desired event.

Expected Results:  
Mousing over the clipped element should trigger the "mouseover" event.
(Reporter)

Comment 1

11 years ago
Created attachment 264108 [details]
Full test case

This is a full test case with explanations.
(Reporter)

Comment 2

11 years ago
Created attachment 264109 [details]
Minimal test case

Better test case for regression
Regression range:
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2006-06-09+07%3A00&maxdate=2006-06-09+13%3A00
So it is caused by Bug 340451 I guess. I see no dependencies in this bug so I assume this is a new bug.
Blocks: 340451
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, testcase
OS: Mac OS X → All
Hardware: PC → All
Version: unspecified → Trunk
(Reporter)

Comment 4

11 years ago
I am unable to comment if this bug is related to bug 340451, but since the fix for bug 340451 was applied in June 2006, I am assuming that the fix is present in Grand Paradiso 4.

This test case works on Firefox 2.0.0.3, so it appears to be something new.

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376952
You need to log in before you can comment on or make changes to this bug.