Can't change Preferences: OK doesn't work

VERIFIED DUPLICATE of bug 39205

Status

P3
normal
VERIFIED DUPLICATE of bug 39205
19 years ago
14 years ago

People

(Reporter: pfortin, Assigned: matt)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.14 i686)
BuildID:    2000042809

Unable to change preferences because the OK button does nothing.
got a request
CSSLoaderImpl::DidLoadStyle: Load of URL 'chrome://communicator/skin/pref.css'
failed.  Error code: 16389
JavaScript error:
chrome://global/content/nsWidgetStateManager.js line 128:
this.dataManager.pageData[aPageTag] has no properties

->>>>>>>>>>>>>> Write Clipboard to memory

### The following lines repeat each time OK is clicked
JavaScript error:
chrome://global/content/nsWidgetStateManager.js line 128:
this.dataManager.pageData[aPageTag] has no properties


Reproducible: Always
Steps to Reproduce:
1. start browser
2. Edit>Preferences (remaining steps are what I'm trying to do)
3. Advanced
4. set 2nd cookies option
5. OK doesn't work
6. Cancel
The following is a workaround; though non-obvious because most people would
likely assume OK is broken.
7. Edit>Preferences
8. Repeat steps 3 & 4
9. OK now seems to work

Comment 1

19 years ago
not a dup but in bug 37598 these error messages are also reported

Comment 2

19 years ago
I have this error too, but at another place in the Prefs:

1. Open Foopy
2. Go to Appearance, Show toolbar as...
3. Click every option "Pictures + Text", "Pics only", "Text only" a couple of 
times forth and back
4. Try to hit OK.

Actual result:
The button is pressed but the dialog doesn't close, and this error pops up:

JavaScript error:
chrome://communicator/content/pref/pref-fonts.js line 173: dataObject has no pro
perties

Expected result:
Foopy dialog should close and prefs should be saved

Comment 3

19 years ago
Oh, yea this happened to me on Win2000 and build 2000050208 (current M16 
nightly)

*** This bug has been marked as a duplicate of 39205 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 5

19 years ago
This is reported to still happen.

User was using 2000052508 on Win98.

Updated

19 years ago
Blocks: 40891
vrfy as dup... but pls lemme know if this is still a problem!
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.