Browser crashes on startup

VERIFIED DUPLICATE of bug 37701

Status

P1
blocker
VERIFIED DUPLICATE of bug 37701
19 years ago
14 years ago

People

(Reporter: gerv, Assigned: mjudge)

Tracking

({regression, smoketest})

Trunk
x86
Windows 95
regression, smoketest

Firefox Tracking Flags

(Not tracked)

Details

(URL)

From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (Win95; U)
BuildID:    2000050109

Browser crashes on startup with the following error message:

MOZILLA caused an invalid page fault in
module GKHTML.DLL at 014f:601afd19.
Registers:
EAX=00000000 CS=014f EIP=601afd19 EFLGS=00010206
EBX=00000000 SS=0157 ESP=0068c184 EBP=0068c1c0
ECX=0aa40b30 DS=0157 ESI=80000000 FS=54bf
EDX=0068c1cc ES=0157 EDI=00000000 GS=0000
Bytes at CS:EIP:
8b 08 50 ff 51 2c 85 c6 0f 85 c5 00 00 00 8b 45 
Stack dump:
00000000 0068c1cc 80000000 00000000 0aa5da10 0aa5dda0 602e3dd0 0068c1d4 60d257a5 
0aa5d9f0 602e3dd0 0068c1d4 00000000 00000001 60d253cb 0068c22c 

Works under Linux. 

Starting in Browser-General...
Keywords: regression, smoketest
Target Milestone: --- → M16
Adding keywords.

Gerv

Comment 2

19 years ago
stack trace:

 Trigger Reason:  Access violation 

 Thread ID:   

 Call Stack:    (Signature = nsSelection::GetFrameForNodeOffset 84d4fc97) 
     
   nsSelection::GetFrameForNodeOffset 
                                       
[d:\builds\seamonkey\mozilla\layout\base\src\nsSelection.cpp, line 1797]
     
   nsCaret::SetupDrawingFrameAndOffset 
                                       
[d:\builds\seamonkey\mozilla\layout\base\src\nsCaret.cpp, line 469]
     
   nsCaret::DrawCaret 
                                       
[d:\builds\seamonkey\mozilla\layout\base\src\nsCaret.cpp, line 691]
     
   nsCaret::StartBlinking 
                                       
[d:\builds\seamonkey\mozilla\layout\base\src\nsCaret.cpp, line 384]
     
   nsCaret::SetCaretVisible 
                                       
[d:\builds\seamonkey\mozilla\layout\base\src\nsCaret.cpp, line 169]
     
   PresShell::SetCaretEnabled 
                                       
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 1784]
     
   nsTextEditorFocusListener::Focus 
                                       
[d:\builds\seamonkey\mozilla\editor\base\nsEditorEventListeners.cpp, line 1080]
     
   nsEventListenerManager::HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line 
1089]
     
   nsDocument::HandleDOMEvent 
                                       
[d:\builds\seamonkey\mozilla\layout\base\src\nsDocument.cpp, line 2644]
     
   nsEventStateManager::PreHandleEvent 
                                       
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 
344]
     
   PresShell::HandleEventInternal 
                                       
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3400]
     
   PresShell::HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3340]
     
   nsView::HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 774]
     
   nsView::HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 747]
     
   nsView::HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 747]
     
   nsViewManager2::DispatchEvent 
                                       
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1372]
     
   HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69]
     
   nsWindow::DispatchEvent 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 531]
     
   nsWindow::DispatchWindowEvent 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 548]
     
   nsWindow::DispatchFocus 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3504]
     
   nsWindow::ProcessMessage 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2564]
     
   nsWindow::WindowProc 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 781]
     
   USER32.dll + 0x19d0 (0x77e719d0) 
                                        
     
   USER32.dll + 0x1982 (0x77e71982) 
                                        
     
   ntdll.dll + 0x163a3 (0x77f763a3) 
                                        
     
   nsGfxTextControlFrame::SetFocus 
                                       
[d:\builds\seamonkey\mozilla\layout\html\forms\src\nsGfxTextControlFrame.cpp, 
line 1843]
     
   nsHTMLInputElement::SetFocus 
                                       
[d:\builds\seamonkey\mozilla\layout\html\content\src\nsHTMLInputElement.cpp, 
line 622]
     
   nsEventStateManager::PreHandleEvent 
                                       
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 
438]
     
   PresShell::HandleEventInternal 
                                       
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3400]
     
   PresShell::HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3340]
     
   nsView::HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 774]
     
   nsViewManager2::DispatchEvent 
                                       
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1372]
     
   HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 69]
     
   nsWindow::DispatchEvent 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 531]
     
   nsWindow::DispatchWindowEvent 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 548]
     
   nsWindow::DispatchFocus 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3504]
     
   nsWindow::ProcessMessage 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2568]
     
   nsWindow::WindowProc 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 781]
     
   USER32.dll + 0x19d0 (0x77e719d0) 
                                        
     
   USER32.dll + 0x1982 (0x77e71982) 
                                        
     
   ntdll.dll + 0x163a3 (0x77f763a3) 
                                        
     
   GlobalWindowImpl::Focus 
                                       
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 1215]
     
   nsWebShellWindow::HandleEvent 
                                       
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsWebShellWindow.cpp, line 538]
     
   nsWindow::DispatchEvent 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 531]
     
   nsWindow::DispatchWindowEvent 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 548]
     
   nsWindow::DispatchFocus 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3504]
     
   nsWindow::ProcessMessage 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2564]
     
   nsWindow::WindowProc 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 781]
     
   USER32.dll + 0x19d0 (0x77e719d0) 
                                        
     
   USER32.dll + 0x1982 (0x77e71982) 
                                        
     
   ntdll.dll + 0x163a3 (0x77f763a3) 
                                        
     
   USER32.dll + 0x18d2 (0x77e718d2) 
                                        
     
   nsWindow::DefaultWindowProc 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 807]
     
   USER32.dll + 0x27fe (0x77e727fe) 
                                        
     
   USER32.dll + 0x2889 (0x77e72889) 
                                        
     
   nsWindow::WindowProc 
                                       
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 792]
     
   USER32.dll + 0x19d0 (0x77e719d0) 
                                        
     
   USER32.dll + 0x1982 (0x77e71982) 
                                        
     
   ntdll.dll + 0x163a3 (0x77f763a3) 
                                        
     
   nsGfxTextControlFrame::SetFocus 
                                       
[d:\builds\seamonkey\mozilla\layout\html\forms\src\nsGfxTextControlFrame.cpp, 
line 1843]
     
   nsGfxTextControlFrame::InstallEditor
                                       
[d:\builds\seamonkey\mozilla\layout\html\forms\src\nsGfxTextControlFrame.cpp, 
line 3047]
     
   EnderTempObserver::OnEndDocumentLoad
                                       
[d:\builds\seamonkey\mozilla\layout\html\forms\src\nsGfxTextControlFrame.cpp, 
line 4825]
     
   nsWebShell::OnEndDocumentLoad 
                                       
[d:\builds\seamonkey\mozilla\webshell\src\nsWebShell.cpp, line 1192]
     
   nsWebShell::SetDocument 
                                       
[d:\builds\seamonkey\mozilla\webshell\src\nsWebShell.cpp, line 1738]

Comment 3

19 years ago
mjudge
Assignee: asadotzler → mjudge
Priority: P3 → P1

Comment 4

19 years ago
This is a dup of 37701.  That bug covers both creation of new profile and use of 
existing profile.  Both crash on startup at the same point.

*** This bug has been marked as a duplicate of 37701 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 5

19 years ago
*** Bug 37729 has been marked as a duplicate of this bug. ***

Comment 6

19 years ago
*** Bug 37733 has been marked as a duplicate of this bug. ***

Comment 7

19 years ago
Sorry for the spam.  New QA Contact for Browser General.  Thanks for your help
Joseph (good luck with the new job) and welcome aboard Doron Rosenberg
QA Contact: jelwell → doronr

Comment 8

19 years ago
Compared stack traces. It appears that the profile issues appear identical. 
Confirming duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.