SMTP in Thunderbird 2 RC1 does not work with SSL

RESOLVED WORKSFORME

Status

Thunderbird
General
--
major
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: Ehsan, Assigned: Scott MacGregor)

Tracking

x86
Windows XP
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3 Creative ZENcast v1.02.10
Build Identifier: version 2.0.0.0 (20070326)

I installed Thunderbird 2 RC1 using the same profile as my Thunderbird 1.5.0.10 installation.  I have configured a few SMTP accounts, which used a couple of SMTP servers with SSL-enabled connections.  One of the SMTP servers is gmail's smtp.gmail.com.  Any attempt to send email through these servers results in the following error:

"Sending of message failed.
The message could not be sent because connecting to SMTP server smtp.gmail.com failed.  The server may be unavailable, or is refusing SMTP connections.  Please verify that your SMTP server setting is correct, and try again, or else contact your network administrator."

The gmail SMTP server doesn't provide non-encrypted connections, but the same error message appears with the TLS, "TLS, if available" and SSL settings.  With the other server, which provides regular SMTP server as well, I can send mail if I disable encryption, but using any of the 3 settings above causes the same error message.

I'm ready to help locate the problem.  Is there any option in Thunderbird which provides a log file of its SMTP connection attempts?

Reproducible: Always

Steps to Reproduce:
Try sending mail through an SSL or TLS enabled SMTP server.
(Reporter)

Updated

11 years ago
Flags: blocking-thunderbird2?
Version: unspecified → 2.0
(Reporter)

Comment 1

11 years ago
I'm not sure if this is related to bug 368611 or not...

Comment 2

11 years ago
Create an smtp log 
<http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#smtp>
(Reporter)

Comment 3

11 years ago
Created attachment 261756 [details]
The Thunderbird SMTP log

(In reply to comment #2)
> Create an smtp log 
> <http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#smtp>
> 

Here it is.
(Reporter)

Updated

11 years ago
Attachment #261756 - Attachment mime type: application/octet-stream → text/plain

Comment 4

11 years ago
Since the connection seems not to be working, my bet is on a antivirus/firewall problem. 
(Reporter)

Comment 5

11 years ago
(In reply to comment #4)
> Since the connection seems not to be working, my bet is on a antivirus/firewall
> problem. 

But Thunderbird 1.5.0.10 on the same machine using the same profile works perfectly.  I have tried disabling my Antivirus and Firewall software as well, but nothing changed.

Comment 6

11 years ago
Software firewalls can block per binary, but since you disabled the firewall it shouldn't affect the connection anymore.

Is the server answering if you do telnet <server> <port> ?

Try also setting nsSocketTransport:5,nsHostResolver:5 in addition to SMTP:5 in the logging to see it it shows anything interesting.
(Assignee)

Comment 7

11 years ago
Kai, I wonder if this is a dupe of some of the other SMTP over SSSL/TLS bugs we've been looking at.
(Assignee)

Updated

11 years ago
Blocks: 378635
(Reporter)

Comment 8

11 years ago
I have performed a lot of tests, and it seems that now I can send mails through SSL-enabled SMTP once in a while.  Specifically, when I'm using the Internet heavily in other applications, it seems that SSL-enabled SMTP connections cannot be made.  The bug shows a lot less when there's no other net usage on the machine.  But SSL-enabled POP3 connections work flawlessly in any case, and furthermore, I have witnessed this problem only since I installed Thunderbird 2 (1.5 didn't have this problem with any kind of net usage.)

Comment 9

11 years ago
Are you always using the GMAIL SMTP server? I've configured one account to use that SMTP server, and I have no problems using it with TB 2.0...is there anything interesting about your network or pc setup?
(Reporter)

Comment 10

11 years ago
The same thing happens with another SMTP server as well.  In fact, if one of these two SMTP servers work at a given time, the other would work too, and if one doesn't, the other one does not as well.  That is why I don't suspect it has anything to do with a particular server.

Like I said in comment #8, the problem seems to show itself when I'm using the Internet in other applications as well.  My connection's downstream and upstream bandwidth are 128 and 32kbps respectively, so I suspect this problem would not be traceable on broadband connections.  Other than this, I don't think there is anything special about my setup.
(Reporter)

Comment 11

11 years ago
Created attachment 262871 [details]
The Thunderbird SMTP/nsSocketTransport/nsHostResolver log

(In reply to comment #6)
> Is the server answering if you do telnet <server> <port> ?

Yes.

> Try also setting nsSocketTransport:5,nsHostResolver:5 in addition to SMTP:5 in
> the logging to see it it shows anything interesting.

Here you are.  I started Thunderbird, and I had a few messages in the Unsent folder which Thunderbird tried to send as soon as it was started (through smtp.gmail.com), but was not successful.  The log file may contain other entries related to retrieval of the RSS feeds that I have.  I didn't know how to turn off that feature in order to produce a smaller (and more focused) log file.  After one SMTP error message, I closed Thunderbird immediately.

Comment 12

11 years ago
I have that problem too, but on Thunderbird 2.0 Release. I was trying to switch  all of my firewalls but nothing happend. Only when I install Thunderbird 1.5.10 I can send, and recieve mail with SSL. I use IMAP and SMTP over SSL. I think that problem in method which get secure cert from mail-server.

PS. Excuse me for my english.
(Reporter)

Comment 13

11 years ago
(In reply to comment #12)
> I have that problem too, but on Thunderbird 2.0 Release. I was trying to switch
>  all of my firewalls but nothing happend. Only when I install Thunderbird
> 1.5.10 I can send, and recieve mail with SSL. I use IMAP and SMTP over SSL. I
> think that problem in method which get secure cert from mail-server.
> 
> PS. Excuse me for my english.

Well, Thunderbird 2 RC1 is the same version as its release version, so I guess we are both having the same problem.  Could you generate the log file as specified in comment #2 and comment #6, so that people can compare the files from both our setups?

Thanks!

Comment 14

11 years ago
LOG Of my smtp connection:
0[274790]: SMTP Connecting to: private.mailserver.com
LOG Of my IMAP connection:
  0[274780]: 28e42d8:private.mailserver.com:NA:SetupWithUrl: clearing IMAP_CONNECTION_IS_OPEN
2784[27c1fc0]: ImapThreadMainLoop entering [this=28e42d8]
2784[27c1fc0]: 28e42d8:private.mailserver.com:NA:ProcessCurrentURL: entering
2784[27c1fc0]: 28e42d8:private.mailserver.com:NA:ProcessCurrentURL:imap://s78@private.mailserver.com:993/select%3E%5EINBOX:  = currentUrl
2784[27c1fc0]: ReadNextLine [stream=291f9b0 nb=0 needmore=1]
2784[27c1fc0]: 28e42d8:private.mailserver.com:NA:CreateNewLineFromSocket: clearing IMAP_CONNECTION_IS_OPEN - rv = 804b0014
2784[27c1fc0]: 28e42d8:private.mailserver.com:NA:TellThreadToDie: close socket connection
2784[27c1fc0]: 28e42d8:private.mailserver.com:NA:CreateNewLineFromSocket: (null)
2784[27c1fc0]: 28e42d8:private.mailserver.com:NA:ProcessCurrentURL: aborting queued urls
2784[27c1fc0]: ImapThreadMainLoop leaving [this=28e42d8]
JFY.
As described in Bug 185662 and Bug 368611 Comment #1, "TLS"/"SSL" in current SMTP setting is misleading/confusing, and "TLS"=STARTTLS and "SSL"=SMTP-over-SSL.
Change by Bug 185662 seems to be still Seamonkey trunk only (See Bug 185662 #22).
Please distinguish problem when setting "TLS" and setting "SSL" clearly.

To Ehsan Akhgari(bug opener): Please change summary in order to avoid misleading. (your problem looks to be "SMTP over SSL" issue.)
(In reply to comment #14)
> LOG Of my IMAP connection:
To Grigoriy: This bug is for SMTP related issue, although same cause(certificate related issue) can be suspected as you say. Please search bugzilla for already opened bug for IMAP/SSL(or TLS) related problem for ease of problem analysis (one problem per a bug), and set dependency to this bug if similarity is found.
(Reporter)

Comment 17

11 years ago
(In reply to comment #15)
> To Ehsan Akhgari(bug opener): Please change summary in order to avoid
> misleading. (your problem looks to be "SMTP over SSL" issue.)

Done.
Summary: SMTP in Thunderbird 2 RC1 does not work with SSL or TLS → SMTP in Thunderbird 2 RC1 does not work with SSL
(Reporter)

Comment 18

11 years ago
(In reply to comment #16)
> (In reply to comment #14)
> > LOG Of my IMAP connection:
> To Grigoriy: This bug is for SMTP related issue, although same
> cause(certificate related issue) can be suspected as you say. Please search
> bugzilla for already opened bug for IMAP/SSL(or TLS) related problem for ease
> of problem analysis (one problem per a bug), and set dependency to this bug if
> similarity is found.

Hmmm, I should note here that the same problem doesn't seem to occur with the POP3 service on the same servers.

Comment 19

11 years ago
This might be a duplicate of bug 368611.

But I don't know yet. The two bugs are only similar.
For now I'm adding a dependency only.
Depends on: 368611

Comment 20

11 years ago
(In reply to comment #19)
> This might be a duplicate of bug 368611.

I was informed that bug 368611 is quite specific to sslio/MatrixSSL

Ehsan, do you see your problem?  I encountered this with one user, and after some time he determined some firewall software was at fault.
(Reporter)

Comment 21

11 years ago
(In reply to comment #20)
> (In reply to comment #19)
> > This might be a duplicate of bug 368611.
> 
> I was informed that bug 368611 is quite specific to sslio/MatrixSSL
> 
> Ehsan, do you see your problem?  I encountered this with one user, and after
> some time he determined some firewall software was at fault.

The only thing that I've found suspicious is the fact that it happens only when I've got a bad/slow Internet connection.  But the same thing works with the POP3 servers, and also it used to work in older Thunderbird versions.

Updated

10 years ago
Flags: blocking-thunderbird2?

Comment 22

10 years ago
Ehsan: is this still a problem? (Is it a problem with trunk build too?)
(Reporter)

Comment 23

10 years ago
Nope, I haven't seen this recently on branch.  I don't use Thunderbird trunk builds that much so I can't comment on it.

Comment 24

10 years ago
->WFM then
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.