[Meta] Accessibility review of new Page Info screen

RESOLVED FIXED in Firefox 3 beta3

Status

()

Firefox
Page Info Window
P3
normal
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Aaron Leventhal, Assigned: MarcoZ)

Tracking

({access, qawanted, sec508})

Trunk
Firefox 3 beta3
access, qawanted, sec508
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: FIXED?)

Attachments

(3 obsolete attachments)

(Reporter)

Description

11 years ago
The new page info screen has not gone through an accessibility review.

It needs to be tested with Window-Eyes, JAWS, LSR and Orca to look for problems.

Right off the bat I noticed the MSAA focus events weren't being fired as I arrowed across the buttons on the top, which means those items wouldn't get spoken.

Don't bother testing with LSR and Orca until we fix the Linux crasher bug 377767.
Summary: Accssibility review of new Page Info screen → Accessibility review of new Page Info screen
Version: 2.0 Branch → Trunk

Comment 1

11 years ago
Category list: Screen readers report five items, but there seem to be only four.  Is there a fifth that only appears in certain situations?

General, Media, work as expected.

Permissions: Tab only identifies "use default check box" instead of reading each option.
Actual: "Use default check box checked".
Expected: Cookies: Use Default check box checked".

Once a check box is unchecked, it's associated radio buttons aren't grouped with the option.  Actual: "Allow radio button checked".
Expected: "Cookies: allow radio button checked".

Security: Window-eyes works as expected. 
Jaws: Website identity group works as expected.  
Privacy group: Jaws does not speak the label of each field, only the Privacy grouping.
Actual: "Privacy: read-only edit read-only: no".

Expected/Window-eyes: Privacy History: Have I visited this website before today?: read-only edit: no".

Jaws has excessive verbiage:
Actual: "Website identity verified by: read-only edit read-only: Thawte Consulting".
Expected: Website identity verified by: read-only edit: Thawte Consulting".  

Jaws verbiage problem is ongoing, not associated with this bug.
  
(Reporter)

Comment 2

11 years ago
Tim, can you ask the appropriate front-end folks whether they want separate bugs filed for each of those items?

Most of the work should be marked as blocking Firefox 3 unless there's a good reason not to.
Flags: blocking-firefox3?
(Assignee)

Comment 3

11 years ago
Using Orca 2.19.90 pre and Minefield from August 3:
1. Page tabs are not spoken as such. Orca only says "General" without giving a specific window type.
2. General Page:
a) The first Text field has no label spoken, and Orca does not detect one using flat review.
b) Security Information for this Page: Panel title is spoken, Associated text is not spoken, only the More button is announced.
3. Media Page:
a) Address column header is spoken, but right arrowing does not speak Type column header. Instead, focus jumps to the next address (using the Minefield start page as an example), another Right Arrow jumps to the type "background".
4. Permissions Page:
a) Permissions for: label is not spoken.
b) Load Images, Open Popup Windows, Set Cookies, Install Extensions or Themes: All these panel labels are not spoken. Orca only announces "use defaults checkbox checked" for each item.
c) Same is true for the radio buttons if one of the above checkboxes is unchecked. The panel labels are also not spoken for any of the radio buttons.
5. Security Page:
a) Privacy and History Panel: None of the labels for the edits are spoken. The label of the panel itself is spoken when first tabbing into it.

Comment 4

11 years ago
According to Accerciser, I see the following problems/oddities:

1)  There is an extra scrollpane with an empty list as a child between the Media and Permissions panes.  
2) There are no label relations set for the Permissions items.
3) The Media scrollpane->tree has an odd hierarchy.  It contains a 'list' with 'table cell' children, including three extra children.  Each extra child is a repeat of the last valid child.
4) Much of the textual information shows up as an 'entry' instead of 'text'.  
(Reporter)

Comment 5

11 years ago
Regarding Scott Haeger's comment 4:
For item #2 (no label relations), that seems like an obvious problem where they probably forgot the control attribute for <label> and <description> elements.
For item #4 (ROLE_ENTRY instead of TEXT), that must mean they used <textbox> -- perhaps readonly textboxes. That might be on purpose to make it easier to copy and paste the text.
Flags: blocking-firefox3? → blocking-firefox3+

Updated

11 years ago
Keywords: qawanted
Target Milestone: --- → Firefox 3 M9

Comment 6

11 years ago
Why is there qawanted on this bug?  In the latest-trunk from today, 09-07-04, the groupings are still not spoken on the Permissions tab.

Updated

11 years ago
Target Milestone: Firefox 3 M9 → Firefox 3 M10
(Assignee)

Comment 7

11 years ago
I am currently testing out fixes for some of these, especially the groupings and one of the missing label relations, which is actually only a typo in the id (a lowercase t instead of an uppercase T). There is one major issue, regarding the Security And Privacy page: Sentences like "Have I visited this web site before?" etc., are XUL:description elements. They must be, because they may wrap, as seen in one instance. And even though these XUL:description elements have a control attribute, the XUL accessibility does not associate them as labels with the desired controls.
Aaron, would it be feasible to implement something like this:
1. If a XUL:description element has a control attribute, treat it as if it was a label for a control.
2. If it does not, use the current behaviour/accessibility implementation.
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 8

11 years ago
Created attachment 282036 [details] [diff] [review]
Experimental patch

This patch addresses the following issues:
1. HostName label not spoken. This was a simple typo, a lower-case t was being used where an upper-case T would have been appropriate.
2. Associated the labels for the different permissions radio groups. This does not solve the problem of the checkboxes only speaking "Default", but not which item should be left at the default.
3. On the Security & Privacy page, added hidden labels for the textboxes whose prompts are not spoken by JAWS and Orca.
On this, I have the following questions:
1. Is the visual appearahce of the dialog page altered by adding a hidden label?
2. Is this a proper method to explicitly label something for accessibility if no visually visible cues are possible?
(Assignee)

Updated

11 years ago
Assignee: nobody → marco.zehe
Status: ASSIGNED → NEW
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 9

11 years ago
Created attachment 282112 [details] [diff] [review]
Second experimental patch

This patch gets rid of the hidden labels, and converts the XUL:description elements into XUL:label elements. If the label's caption is enclosed within opening and closing tags like XUL:description elements, it also wraps. So simply changing the tag was sufficient to get things talking, and still retain the normal visual layout.
Joanie, can you test this on Linux and see if you find anything odd?
Attachment #282036 - Attachment is obsolete: true
(Assignee)

Comment 10

11 years ago
Created attachment 282300 [details] [diff] [review]
Patch 3, addressing groupboxes on Permissions page

This patch assigns the wairole:group to the boxses that enclose the checkboxes. Once bug 388185 is checked in, this should enable all the groupboxes to speak properly. It worked with JAWS with my compiled test build that also contains patch for bug 388185.
Attachment #282112 - Attachment is obsolete: true
(Assignee)

Updated

11 years ago
Attachment #282300 - Attachment is obsolete: true
(Assignee)

Comment 11

11 years ago
Turning this bug into a metabug that depends on at least two other bugs that I'll create shortly.
Summary: Accessibility review of new Page Info screen → [Meta] Accessibility review of new Page Info screen
(Assignee)

Updated

11 years ago
Depends on: 398170
(Assignee)

Updated

11 years ago
Depends on: 398176

Updated

11 years ago
Target Milestone: Firefox 3 M10 → Firefox 3 M11

Comment 12

11 years ago
Should this be closed up or is there something else to do?  All dependencies have been fixed.

Updated

11 years ago
Priority: -- → P3
Whiteboard: FIXED?
(Assignee)

Comment 13

11 years ago
Setting this bug to resolved. All bugs this bug depends on have been resolved.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Updated

11 years ago
Duplicate of this bug: 347215
You need to log in before you can comment on or make changes to this bug.