Attachments not exposed via MSAA in Thunderbird 3

RESOLVED WORKSFORME

Status

Thunderbird
Message Reader UI
P1
normal
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: Rick, Unassigned)

Tracking

(Blocks: 1 bug, {access})

Trunk
x86
Windows XP
access
Bug Flags:
blocking-thunderbird3 -
wanted-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060917 Firefox/1.5.0.7
Build Identifier: 2.0.0.0 (20070326)

When a message containing an attachment is displayed in the main Thunderbird window, the attachment is not visible via MSAA.

NOTE:  This is fixed in the 3.0 version.  I am requesting that the fix be migrated back into version 2.

Reproducible: Always

Steps to Reproduce:
1. View a message containing an attachment in the main Thunderbird window (or open the message in its own window)
2. Examine the window with AccExplorer
3.
Actual Results:  
No attachment is available via MSAA

Expected Results:  
The attachment would be accessible via MSAA.
(Reporter)

Comment 1

11 years ago
David Bolter (david.bolter@utoronto.ca) said this should be assigned to him.
Keywords: access
You probably ought to at least cc him, then.

A more usual approach for getting thing on a branch is to find the bug that fixed it on the trunk, and ask the patch author and/or reviewers to request branch approval, if they feel it's branch-safe.
Assignee: mscott → david.bolter

Comment 3

11 years ago
(In reply to comment #0)
> NOTE:  This is fixed in the 3.0 version.  I am requesting that the fix be
> migrated back into version 2.

I cannot confirm this to be fixed for Windows in latest Trunk builds of Thunderbird. It is working fine in Linux, but on Windows, the information that a message contains an attachment is NOT available through MSAA.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk

Comment 4

10 years ago
This is still the case in latest Trunk. Requesting blocking since this is information a user must know.
Flags: blocking-thunderbird3?
Marco, can you include steps to test this feature?  
Triaging according to new policy for flags.  
https://wiki.mozilla.org/Thunderbird:Release_Driving

Marco, could you give us details on how we can test this? Thanks.
Flags: wanted-thunderbird3+
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3-
Priority: -- → P1
Target Milestone: --- → Thunderbird 3.0rc1
Assignee: david.bolter → nobody

Comment 7

10 years ago
To test this, focus a message that has an attachment.
If not already installed, install DOM inspector.
Open DOM inspector, switch to Accessible Tree, and navigate down to the listitem accessibles.

On Windows, the message that contains the attachment does not have the info present that there is an attachment.
On Linux, this gets exposed.

Updated

9 years ago
Component: Mail Window Front End → Message Reader UI
QA Contact: front-end → message-reader
Target Milestone: Thunderbird 3.0rc1 → ---
Summary: Attachments not exposed via MSAA in Thunderbird 2 → Attachments not exposed via MSAA in Thunderbird 3

Comment 8

8 years ago
Marco, could you retest this again?

Comment 9

8 years ago
This started working on Windows when we switched the messages list to be exposed as a full-fledged table.
(In reply to comment #9)
> This started working on Windows when we switched the messages list to be
> exposed as a full-fledged table.

so WFM based on comment 9. Marco if you disagree please reopen.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.