Mozilla still has glitches to pass the acid2 (acid 2) test correctly

RESOLVED DUPLICATE of bug 289480

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 289480
10 years ago
10 years ago

People

(Reporter: Sierk Bornemann, Unassigned)

Tracking

({regression})

Trunk
x86
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a4pre) Gecko/20070418 Minefield/3.0a4pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a4pre) Gecko/20070418 Minefield/3.0a4pre

Firefox still has glitches to pass the acid2 test correctly, especially on MacOSX.
Attention to the rendering of the nose.
Attention to the rendering of the black blocks forming the outline.
Attention to the used default font while making the test, which differs between the platforms, meaning MacOSX and Windows.

Reproducible: Always

Steps to Reproduce:
1. Create a plain vanilla default Firefox profile to ensure optimal premises to run the Acid2 test.
2. Run the Acid2 test and look to the rendering of the black outline blocks.
3. Compare with the Acid 2 reference page.
4. Change the default font in Firefox's preference pane from "Times" (Default serif font on MacOSX) to "Times New Roman" (Default serif font on Windows).
5. Compare again with the Acid 2 reference page.
Actual Results:  
Still a glitch with the border rendering of the nose. This issue might to be accepted because of different rendering models of the browsers according to Bug 343583.

Still a glitch with the lower left border of the nose. This issue might depend
on Bug 368247, which should be a blocker for all bugs concerning the Acid2 test.

Still issues painting the borders correctly at all on MacOSX. Relying on the browser's default preferences, nearly all black outline borders are painted a few pixels too low than they should. Couriously this issue improves, if you select "Times New Roman" instead of "Times" (the latter is the default serif font selection on MacOSX in contrast to Windows) as the default serif font. In that case, only the upper top black block of the outline
is rendered 2 pixels too low, the rest of the outline blocks are rendered
correctly.

Expected Results:  
Render the Acid2 test correctly/exactly without any differences to the Acid 2 referende page, cross-platform-wise without any exception to any platform.

Conclusion: Under this impression, Bug 289480 doesn't fulfill my claim, a bug has to fulfill to be marked as "Fixed". I guess, this is a regression case. The topic "Acid2 test" should be re-opened, especially for Firefox on MacOSX.
(Reporter)

Comment 1

10 years ago
Created attachment 261989 [details]
Screenshot Acid 2 test on Firefox 2006-04-18 with default browser preferences/default font
(Reporter)

Comment 2

10 years ago
Created attachment 261990 [details]
Screenshot Acid 2 test on Firefox 2006-04-18 with default browser preferences/Times New Roman font
(Reporter)

Updated

10 years ago
Blocks: 289480
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Version: unspecified → Trunk
Did you reload the test after changing the font?  You need to scroll to the right position.
I suspect the Mac-only nose glitches are bug 361523.

But this really looks like another meta-bug, not another report on specific issues that was requested, and we don't need more than one.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 289480
(Reporter)

Comment 5

10 years ago
(In reply to comment #3)
> Did you reload the test after changing the font?  You need to scroll to the
> right position.

Yes, I did.

What we need are bugs on specific issues, not another single metabug that bugs are still present.
No longer blocks: 289480
(Reporter)

Comment 7

10 years ago
(In reply to comment #6)
> What we need are bugs on specific issues, not another single metabug that bugs
> are still present.

I have relied to the status "Fixed" of Bug 289480 and have been disappointed, that this information doesn't seem to be true relating MacOSX. So, I have tested and filed this bug to point the attention to this issue again. Before the news spreads around the world, that Firefox at long last passes the Acid 2 test, we should assure, that this truely is the case for any supported platform. In any case not fulfilling the needs, Bug 289480 should not be marked as "Fixed" to avoid any false expectation.

Comment 8

10 years ago
As per discussion in bug 289480, this bug should be not a 'duplicated' but a 'blocks' bug to 289480. This bug is a very specific issue, with the nose, fonts and MacOSX keywords.

And can this be retested with a current build?
It is possible that with the new border drawing code this issue is no longer valid...
(see comment #4: I suspect the Mac-only nose glitches are bug 361523)
Blocks: 289480
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 9

10 years ago
The Acid2 test has been displaying correctly on OS X for a long time.
The glitches in the nose have been fixed by bug 361523.

Comment 10

10 years ago
So, we can close this one and even bug 289480 ?

Comment 11

10 years ago
(In reply to comment #8)
> This bug is a very specific issue, with the nose, fonts and MacOSX keywords.

It's not specific, it's a list of things that are different from the reference
rendering. Separate bugs should be filed on individual issues, with minimized
testcases for each problem.

Please don't close bug 289480, otherwise people will complain about the resolution each time we have a layout regression.

Updated

10 years ago
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 289480
(Reporter)

Comment 13

10 years ago
(In reply to comment #9)
> The Acid2 test has been displaying correctly on OS X for a long time.
> The glitches in the nose have been fixed by bug 361523.

Although Bug 361523 might be fixed, I won't agree, that the glitches in the nose have been fixed either. I still see these glitches with Firefox nightly, Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a5pre) Gecko/20070520 Minefield/3.0a5pre (fresh profile installed, default settings).
Fortunately, the nose's glitches are the only flaws so far, I can see concerning Acid2. I hope, this little issue on Firefox/MacOSX could also be solved shortly. :-)

Updated

10 years ago
No longer blocks: 289480
You need to log in before you can comment on or make changes to this bug.