SpamAssasin typo in mailnews.js - causes "trust spamassassin" not to work

VERIFIED FIXED in Thunderbird 3

Status

--
major
VERIFIED FIXED
12 years ago
8 years ago

People

(Reporter: philor, Assigned: philor)

Tracking

({verified1.8.1.12})

Trunk
Thunderbird 3
verified1.8.1.12
Bug Flags:
blocking1.8.1.12 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
Created attachment 262392 [details] [diff] [review]
Fix v.1

Discovered thanks to a strange and terrible thread in m.d.a.seamonkey. STR are hard to come by - I suspect that extension .sfd come first, and would work as a step, but otherwise you either have to fool your filesystem into delivering something before SpamAssassin.sfd, or have both SpamAssassin.sfd and SpamAssasin.sfd, to see that sin.sfd is selected by default, rather than ssin.sfd.
Attachment #262392 - Flags: superreview?(mscott)
Attachment #262392 - Flags: review?(mscott)

Comment 1

12 years ago
I can choose between
  SpamAssasin
  SpamAssassin
  SpamPal
in Seamonkey 1.1

Question: I can choose "SpamAssasin" in Seamonkey(german (at).
Has this to do with this bug here?
And will this seamonkey bug get fixed with your fix here in seamonkey, too?

Thank you for your answer.

Comment 2

12 years ago
Comment on attachment 262392 [details] [diff] [review]
Fix v.1

good catch!
Attachment #262392 - Flags: superreview?(mscott)
Attachment #262392 - Flags: superreview+
Attachment #262392 - Flags: review?(mscott)
Attachment #262392 - Flags: review+
(Assignee)

Comment 3

12 years ago
mailnews/mailnews.js 3.296

(In reply to comment #1)
> Has this to do with this bug here?

Not really, no; replied in m.d.a.seamonkey instead.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Updating summary and severity as is seems this was causing bug 381589.
Severity: minor → major
Summary: SpamAssasin typo in mailnews.js → SpamAssasin typo in mailnews.js - causes "trust spamassassin" not to work
Comment on attachment 262392 [details] [diff] [review]
Fix v.1

This very safe little patch should go on branch too, as it seems to fix bug 381589.
Attachment #262392 - Flags: approval1.8.1.12?
Duplicate of this bug: 381589
(Assignee)

Comment 7

11 years ago
Oh, crap. Yes, this is a good branch-safe workaround for the broken-by-design way am-junk handles the default value.
Flags: blocking1.8.1.12?
Not blocking, but we'll look at the patch.
Flags: blocking1.8.1.12? → blocking1.8.1.12-
Comment on attachment 262392 [details] [diff] [review]
Fix v.1

approved for 1.8.1.12, a=dveditz for release-drivers
Attachment #262392 - Flags: approval1.8.1.12? → approval1.8.1.12+
(Assignee)

Comment 10

11 years ago
mailnews/mailnews.js 3.249.2.39
Keywords: fixed1.8.1.12
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.1.12 → verified1.8.1.12
(Assignee)

Updated

11 years ago
Duplicate of this bug: 381589

Updated

8 years ago
You need to log in before you can comment on or make changes to this bug.