Closed Bug 37843 Opened 20 years ago Closed 20 years ago

Shop@Netscape should not be in mozilla

Categories

(SeaMonkey :: Search, defect, P3)

x86
Windows 98
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 30653

People

(Reporter: sammy_ford, Assigned: johng)

References

Details

It seems as if netscape shop has been added to mozilla, shouldn't this be in the 
commercial tree?
rjc, this stuff belongs in the ns tree somewhere.

Blocks: 14532
For everyone who DOESN'T want some search engines in Mozilla, there is someone 
else who does.  For example, see bug # 32586 for requests to add more engines.

I personally believe that Mozilla should accept search files from any 
official contributor (whether Netscape or anyone else) barring legal issues.  
So, if JoeUser submitted a search file for "Google" we should not accept it.  
However, if someone directly from Google submitted a search file for their web 
site, Mozilla should accept it.

Basically, the more search engines that are there, the more valuable the search 
sidebar panel is for the user.  If Mozilla basically has no search engines in 
it, then the search functionality in Mozilla won't function and will receive 
little testing.

Reassigning this bug to marketing, and cc'ing mitchell@mozilla.org
Assignee: rjc → johng
Mozilla should propbaly include the top <= 10 search engines or so. (We propably
wouldn't want to have a Microsoft search engine (or something similar) in there,
even if it were part of the top 10 :) .)

Shop@Netscape certainly is not part of them. If you include Shop@Netscape, why
not ebay? Its competitors? Maybe amazon? egghead?

Please remove Shop@Netscape.

> [...] legal issues. So, if JoeUser submitted a search file for "Google" we
> should not accept it. However, if someone directly from Google submitted a
> search file for their web site, Mozilla should accept it.

What legal issues? It is OK to include a search engine in the bookmarks by
default. HTML clients have the freedom of presentation. => JoeContributor should
should be able to submit new search files. If they are accepted depends on the
Mozilla community.

-- Additional Comments From amitp@google.com 2000-04-27 12:59 in bug 32586 --
> One problem seems to be that the search engine companies aren't going to
> guarantee that their HTML is formatted in any particular way.  If Netscape
> distributes Sherlock plug-ins for search engine XYZ, and XYZ changes its
> HTML, then users will complain to Netscape.
> That's no reason not to put them in Mozilla, though.  :-)
> What legal issues?

One example: Many major search engines strictly prohibit redisplaying of their 
copyrighted content in any form other than what they present it as.
> One example: Many major search engines strictly prohibit redisplaying of their
> copyrighted content in any form other than what they present it as.

How do "they present it as"? There's no "correct" way to display HTML. It is by
definition completely up to the client, what to do with it.
I'm not going to argue this point. Its merely a fact. We do re-display search 
results in an altered form.
Folks, most of this discussion has already taken place in bug 30653. (Is this a
dup?)

BenB: Top ten? That's a totally arbitrary distinction. On what logical,
defensible basis would you rationalize not including a particular search
service? And why *wouldn't* we want a Microsoft search engine??? It appears to
be okay with you for mozilla.org to have overt prejudice about who will and
won't go into the Search feature. While I'm not happy with the situation as it
is now, we *definitely* don't want to go in that direction!

*** This bug has been marked as a duplicate of 30653 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
VERIFIED Dupe
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.