loading startpage when proxy not set as needed gives 100% CPU with busy indicator at thunderbird startup

RESOLVED DUPLICATE of bug 919485

Status

defect
--
minor
RESOLVED DUPLICATE of bug 919485
12 years ago
3 years ago

People

(Reporter: brian.cox, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: version 2.0.0.0 (20070326)

1. start thunderbird
2. select folder Inbox on the left
3. CPU runs at 100% with busy indicator and "Loading message..." message on lower left until a message is selected in the window on the right

cause: thunderbird is trying to access the startup page but there's a proxy and it is not configured to access the net through a proxy.  Doing the configuration or turning off the startup page is a workaround for this issue.

Reproducible: Always

Steps to Reproduce:
1. see above
2.
3.
Summary: 100% CPU with busy indicator at thunderbird startup → loading startpage when proxy not set as needed gives 100% CPU with busy indicator at thunderbird startup
Version: unspecified → 2.0
Assignee: mscott → nobody
Brian, doyou still see this?
Keywords: perf
Reporter

Comment 2

10 years ago
Wayne, I am -- thankfully -- no longer on a proxied connection to the Net, so, no, I haven't seen this but that's no indication that it still doesn't happend
Brian, tahnks for the feedback.
-> incomplete
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INCOMPLETE

Comment 4

5 years ago
This old bug does still exist with Thunderbird 24.3.0.
When using Thunderbird behind a firewall that requires a (socks) proxy to connect to the mail server and the proxy is not properly configured, there is a high CPU load until the connection times out. Obviously there is some busy loop waiting for the connection.

Comment 5

5 years ago
As I wrote for bug 919485, it is straightforward (for anyone on any version!) to reproduce this bug:
Simply put any garbage IP address and port number in the HTTP proxy settings,
then for instance search for add-ons via Tools->Add-Ons.

This phenomenon is still present in TB 31.2.0, and likewise in FF 33.1.
I wonder why this 7+ years old bug is still marked as RESOLVED INCOMPLETE.

Moreover, those ugly battery-wasting bugs due to busy loop(s) on connect should hot be too hard to correct. My guess is that all of them can be traced down to a single careless chunk of low-level code.
perhpas a duplicate of bug 919485
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 919485
You need to log in before you can comment on or make changes to this bug.