[FIX]Implement "content: none"

RESOLVED FIXED in mozilla1.9alpha5

Status

()

Core
CSS Parsing and Computation
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: bz, Assigned: bz)

Tracking

(Blocks: 1 bug)

Trunk
mozilla1.9alpha5
x86
Linux
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Created attachment 262584 [details] [diff] [review]
Fix

It's easy; might as well
Attachment #262584 - Flags: superreview?(dbaron)
Attachment #262584 - Flags: review?(dbaron)
Created attachment 262585 [details] [diff] [review]
With tests too
Attachment #262585 - Flags: superreview?(dbaron)
Attachment #262585 - Flags: review?(dbaron)

Comment 2

10 years ago
Is the first hunk of the patch for a different bug?
er, yes.  And it's already checked in, in fact...
I'm pretty sure this'll turn a few mochitest todos into passing.
Blocks: 377731
Attachment #262584 - Attachment is obsolete: true
Attachment #262584 - Flags: superreview?(dbaron)
Attachment #262584 - Flags: review?(dbaron)
I'll watch out for it.  ;)
Comment on attachment 262585 [details] [diff] [review]
With tests too

r+sr=dbaron

Please update the mochitest todos in test_value_storage.html and test_value_computation.html (by removing the line that notes content:none is unimplemented), and run the mochitests before checkin.  (See bug 279246 comment 41 for instructions if you need them.)
Attachment #262585 - Flags: superreview?(dbaron)
Attachment #262585 - Flags: superreview+
Attachment #262585 - Flags: review?(dbaron)
Attachment #262585 - Flags: review+
Checked in, with the mochitest changes.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: mozilla1.9alpha4 → mozilla1.9alpha5
You need to log in before you can comment on or make changes to this bug.