Viewing history by site in sidebar doesn't organise by site

VERIFIED FIXED in Firefox 3 alpha8

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
10 years ago
7 years ago

People

(Reporter: mossop, Assigned: mano)

Tracking

Trunk
Firefox 3 alpha8
x86
All
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: see comment 4)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
If you open the history sidebar and choode to view by site, the urls are just all listed, there is no organisation by site at all. Viewing by date and site does work as expected, though I appear to have a couple of broken entries like "false;".

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a4pre) Gecko/20070424 Minefield/3.0a4pre ID:2007042402 [cairo]
Created attachment 267790 [details]
Screenshot of build 20070607 on Vista

Dave, still messed up for you?
(Reporter)

Comment 2

10 years ago
All OS as per comment 1. I'm also seeing an issue with the scrollbar not working right but that may be more cocoa widget related.
OS: Mac OS X → All
(Reporter)

Comment 3

10 years ago
For some reason I was under the impression that this was supposed to display a folder view like by date and site does so comment 1 actually shows this working as it should. However mine is still not right, it's just listing the pages in title order.
So...

 * Sort By Site does not group, it just sorts.
 * Sorts, by title.
 * In Fx2 too, and that's not even filed.

I think we should either change this to actually group by host or rename the menu-item to "Sort By Title".
Flags: blocking-firefox3?
Keywords: uiwanted
Whiteboard: see comment 4
(Reporter)

Comment 5

10 years ago
I quite often find myself having to dig through all the date groups to find a result from a given site so I'd vote for proper grouping by site.

That said I was surprised to just realise that there wasnt just a sort by name option, but then I think you can just search in that instance.
Created attachment 270167 [details] [diff] [review]
the former
Assignee: nobody → mano
Status: NEW → ASSIGNED
Attachment #270167 - Flags: review?(mconnor)
Flags: blocking-firefox3? → blocking-firefox3+

Updated

10 years ago
Target Milestone: --- → Firefox 3 M8
Comment on attachment 270167 [details] [diff] [review]
the former

r=me, let's get this landed
Attachment #270167 - Flags: review?(mconnor) → review+

Updated

10 years ago
Duplicate of this bug: 360413
(Reporter)

Comment 9

10 years ago
Created attachment 277880 [details] [diff] [review]
unbitrotted
Attachment #270167 - Attachment is obsolete: true
Thanks Dave.

Checking in browser/components/places/content/history-panel.js;
/cvsroot/mozilla/browser/components/places/content/history-panel.js,v  <--  history-panel.js
new revision: 1.23; previous revision: 1.22
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Updated

10 years ago
Keywords: uiwanted

Comment 11

10 years ago
Is there a bug to implement Sort By Title (the latter option)?
Blocks: 394024
> Is there a bug to implement Sort By Title (the latter option)?

see bug #394024
Blocks: 394027
verified with - Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a8pre) Gecko/2007091304 Minefield/3.0a8pre

sorted by sites shows folders containing pages for each site visited.
Status: RESOLVED → VERIFIED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.