Closed Bug 378839 Opened 13 years ago Closed 13 years ago

unescape of properties files is broken

Categories

(Core :: XPCOM, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: dev-null, Assigned: smontagu)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070425 Minefield/3.0a4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070425 Minefield/3.0a4pre ID:2007042510

unescape of escaped-unicode (\uXXXX format) is broken.

Reproducible: Always

Steps to Reproduce:
1. Go to the URL
Actual Results:  
The image “S” cannot be displayed, because it contains errors.

Expected Results:  
The image “data:image/png,foo” cannot be displayed, because it contains errors.

regression range: between 2007042507 and 2007042508

maybe Bug 365345 causes this.
Seems likely from the regression range
Assignee: nobody → smontagu
http://lxr.mozilla.org/mozilla/source/dom/locales/en-US/chrome/layout/MediaDocument.properties#53
> InvalidImage=The image \u201c%S\u201d cannot be displayed, because it contains errors.

\u201c%S\u201d must be unescaped to “%S”
but it seems actually unescaped to “S”
Blocks: 365345
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attached patch patchSplinter Review
Attachment #262861 - Flags: superreview?
Attachment #262861 - Flags: review?
Attachment #262861 - Flags: superreview?(cbiesinger)
Attachment #262861 - Flags: superreview?
Attachment #262861 - Flags: review?(cbiesinger)
Attachment #262861 - Flags: review?
Comment on attachment 262861 [details] [diff] [review]
patch

sr=biesi, but I'm not an xpcom peer...
Attachment #262861 - Flags: superreview?(cbiesinger)
Attachment #262861 - Flags: superreview+
Attachment #262861 - Flags: review?(cbiesinger)
Attachment #262861 - Flags: review?(benjamin)
We should either get this in for 1.9a4, or back out bug 365345.
Flags: blocking1.9?
actually, perhaps you should use Append(ch) instead of the --i. That may be easier to understand.
OS: Windows XP → All
Hardware: PC → All
How would that work if there were two consecutive escapes?
oh.. you're right. ok, the --i is better :)
Attachment #262861 - Flags: review?(benjamin) → review+
Checked in.
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Flags: in-testsuite?
Flags: in-testsuite?
Flags: in-testsuite+
Flags: blocking1.9?
You need to log in before you can comment on or make changes to this bug.