Add Open Calendar Item in Thunderbird File Menu

VERIFIED FIXED in 0.8

Status

Calendar
Lightning Only
--
enhancement
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: Fallen, Unassigned)

Tracking

unspecified
Dependency tree / graph

Details

Attachments

(1 attachment)

16.18 KB, patch
Michael Büttner (no reviews TFN)
: review+
Christian Jansen
: ui-review+
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
When items are selected in the calendar view, it should be possible to use the menu (File -> Save As -> (ICS?) File) in Thunderbird.

A similar solution might be desirable for Opening ICS files. That kind of depends on how bug 306692 is solved.
(Reporter)

Comment 1

11 years ago
Created attachment 283899 [details] [diff] [review]
[checked in] Add Open functionality

This patch takes care of half of the deal. Aside from the fact that it fixes the rest of bug 392612 by not allowing more than one calendar of the same file url to be opened at once, it adds an "Open" menu item into the Thunderbird file menu, that contains both the existing "Open Saved Message..." item (renamed to "Saved Message...") and a new "Calendar File..." item. We might want to change to just using "Message..." and "Calendar...".

What this patch doesn't fix is adding an item to the "Save As" menu. Since the save as menupopup doesn't have an idea (argh), we might have to add things the hard way. I'll leave that part for another day or someone else.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #283899 - Flags: ui-review?(christian.jansen)
Attachment #283899 - Flags: review?(michael.buettner)
(Reporter)

Updated

11 years ago
Blocks: 392612

Comment 2

11 years ago
The patch is ok, but I'd prefer that Thunderbird switches to Calendar Mode, if a Calendar File has been opened successfully.

Comment 3

11 years ago
Comment on attachment 283899 [details] [diff] [review]
[checked in] Add Open functionality

I forgot to give this one the official ui+.
Attachment #283899 - Flags: ui-review?(christian.jansen) → ui-review+
Philipp, did you test this patch on a Mac? Does it work as expected? I'd test it by myself, but you stole the machine... :-)
(Reporter)

Comment 5

11 years ago
Since the mac cant really filter by filetype, we might consider offering one "Open" dialog that can open both email messages and calendar files. On windows it could offer all applicable filetypes, on the mac we will have to detect the filetype.

Other than the above, the patch works fine on mac.
Comment on attachment 283899 [details] [diff] [review]
[checked in] Add Open functionality

r=mickey
Attachment #283899 - Flags: review?(michael.buettner) → review+
Keywords: checkin-needed
Whiteboard: [checkin-needed after 0.7]
(Reporter)

Comment 7

11 years ago
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Reporter)

Updated

11 years ago
Keywords: checkin-needed
Whiteboard: [checkin-needed after 0.7]
Target Milestone: 1.0 → 0.8

Comment 8

11 years ago
I've verified it with Lt 2007102823. What about save as ics? Are you going to create a follow up bug?
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

11 years ago
Ah yes, I was to quick on closing. Changing summary to reflect remaining problems.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Summary: Add Open/Save As ICS in Thunderbird File Menu → Add Save As ICS in Thunderbird File Menu
(Reporter)

Updated

11 years ago
Assignee: philipp → nobody
Status: REOPENED → NEW
(Reporter)

Updated

11 years ago
Attachment #283899 - Attachment description: Add Open functionality → [checked in] Add Open functionality
(Reporter)

Comment 10

11 years ago
Actually, the remaining pieces are bug 389154
Status: NEW → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
(Reporter)

Updated

11 years ago
Summary: Add Save As ICS in Thunderbird File Menu → Add Open Calendar Item in Thunderbird File Menu

Comment 11

11 years ago
Verified with Lightning 2008012900
Status: RESOLVED → VERIFIED
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.9) Gecko/20071031 Lightning/0.8pre (2008012818) Thunderbird/2.0.0.9 ID:2007103104

VERIFIED
Duplicate of this bug: 418803
You need to log in before you can comment on or make changes to this bug.