Closed Bug 379804 Opened 13 years ago Closed 11 years ago

Block mailto and other external protocol loads if not initiated by user

Categories

(Core :: Networking, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 167475

People

(Reporter: sicking, Unassigned)

Details

(Whiteboard: [sg:low])

This is a bug to cover what was left of bug 181860 after my patch to it was landed.

We should block document loads of external protocol handlers, such as mailto, if the load was initiated automatically on page load, rather than when the user clicked a link containing a mailto url.
Whiteboard: [sg:low]
Duplicate of this bug: 510250
GNAA 'shock site' pages have a habit of seriously abusing this.  I think this should be a priority, maybe for Firefox 4.  I had 100+ thunderbird e-mail composition windows opening up.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 167475
You need to log in before you can comment on or make changes to this bug.