Newsgroup posts not appearing in Google Groups or being sent from Google Groups

VERIFIED FIXED

Status

mozilla.org
Discussion Forums
--
major
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: Samuel Sidler (old account; do not CC), Assigned: justdave)

Tracking

Details

(Whiteboard: waiting on Google)

I submitted two posts to the mozilla.support.planning newsgroup via Google Groups and they never appeared.

Conversely, the following message IDs appeared in that newsgroups but never appeared on Google Groups:

  dvadnYiK5N-EMarbnZ2dnUVZ_qOpnZ2d@mozilla.org
  WcqdnRQ28p_tW6rbnZ2dnUVZ_vGinZ2d@mozilla.org
  mailman.434.1178740253.14330.support-planning@lists.mozilla.org

Those three were sent using Thunderbird, the first two on Mac, the last on Windows.
Assignee: gerv → justdave
Component: Newsgroups → Server Operations
OS: OpenVMS → All
QA Contact: justdave → justin
Hardware: SGI → All
Can you clarify what was posted where and where it didn't go?  The messages that didn't show up on Google were posted via Google?  Or via news.mozilla.org, or via mail?
Component: Server Operations → Newsgroups
OS: All → OpenVMS
QA Contact: justin → justdave
Hardware: All → SGI
Component: Newsgroups → Server Operations
OS: OpenVMS → All
QA Contact: justdave → justin
Hardware: SGI → All
Component: Server Operations → Newsgroups
OS: All → OpenVMS
QA Contact: justin → gerv
Hardware: All → SGI
(Reporter)

Comment 2

11 years ago
Sorry, yeah.

The two posts two m.s.planning were posted using Google Groups and never appeared either on Google Groups or in the newsgroup.

The last three posts (which have message IDs because they partially made it through) were posted using Thunderbird, the first two to the newsgroup directly, the last to the mailing list. These all appeared in the newsgroup but never appeared in Google Groups.
And just to get complete information, what address was used to post them?
(Reporter)

Comment 4

11 years ago
For the ones posted through Google Groups, I used my Gmail account (samuel.sidler).

For the ones posted through Thunderbird, the first two were posted using ss@m.c, the last using chofmann@m.o. (Using short domain names for spammers...)
ok, and those are mozilla.com and mozilla.org respectively for the benifit of anyone from Google looking at this (since I just handed off a link to the bug to my contact over there).
(Reporter)

Comment 6

11 years ago
I'll add the following message ID to the list above. This message was posted to the newsgroup at 2:18am PDT today (May 10) and never appeared in the Google Group.

  sYidnX0KDY7Kft_bnZ2dnUVZ_rWnnZ2d@mozilla.org

It was mailed using Thunderbird from the exact address moznewsgroups@something.to.remove.jesperkristensen.dk

It seems like anything posted to the newsgroup or mailing list is not making its way to Google Groups. That, coupled with the occasional loss of posts made via the Google Groups interface makes it hard to use this newsgroup. Lucy also said she saw this last night when trying to post via Google Groups, so CCing her.
(Reporter)

Comment 7

11 years ago
Today the posts that were made on Google Groups appeared in the newsgroup (and Google Groups). However, the posts made to the newsgroups which never appeared in Google Groups have still not made it to Google Groups.

Some of the posts that made it had a delay of just under two days.
Duplicate of this bug: 380576
I have not yet heard back from Google on my request sent to them on this issue.  I've opened an additional ticket with Giganews this afternoon on the off chance it's something on their side.
Whiteboard: waiting on Giganews and Google

Updated

11 years ago
OS: OpenVMS → All
Hardware: SGI → All

Comment 10

11 years ago
Not sure if this belongs in a separate bug, but I'm starting here.  (it's occuring in an older newsgroup)
bobson@rpg.pl submitted Message-ID 57GdnZxbm55Rm9vbnZ2dnUVZ_qGjnZ2d@mozilla.org news via hendrix.m.o to mozilla.feedback on Sat, 12 May 2007 at 13:26:20 -0500 (a little more than 39 hours ago).  Still nothing in google groups.  IDK what exactly this means but I thought it might be helpful: Xref: number1.nntp.dca.giganews.com mozilla.feedback:41050
From Giganews:

"Google wasn't taking their feed from us.  It looks like their feed server wasn't accepting any articles for a few days, which is well beyond our ability to backlog for them."

Haven't heard back from Google yet, I will ping again.  But the above implies that that was all past-tense.  Can anyone verify if it's working now?
Whiteboard: waiting on Giganews and Google → waiting on Google
(In reply to comment #11)
> Can anyone verify if it's working now?

Anyone?
Sorry, I was going to.

I've successfully posted using the Google Groups interface recently, so that part seems to be working.

That being said, it looks like there was recently two posts that appear in Google Groups which were practically the same, but only one appeared in the newsgroup. [1]

The posts that were made to Google Groups but hadn't at all appeared have now made it, afaict. However, the reverse is not true. Should we expect the posts that didn't make it to Google Groups to appear now?

[1] http://groups.google.com/group/mozilla.support.planning/browse_thread/thread/fa9a1a9b6f6b4ca5/c973007a6357fc85#c973007a6357fc85
(In reply to comment #13)
> The posts that were made to Google Groups but hadn't at all appeared have now
> made it, afaict. However, the reverse is not true. Should we expect the posts
> that didn't make it to Google Groups to appear now?

Most likely not.  According to Giganews, they expired out of the feed queue before Google picked them up because they didn't pull their feed for a few days.  I know from past experience that we're not going to talk anyone into re-pushing a specific range of messages (we've tried it before, from both ends, they both refused).

If everything's working correctly with new messages I'm going to consider this fixed.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 15

11 years ago
Problems still occurring. I posted from Google Groups to this thread

http://groups.google.com/group/mozilla.support.planning/browse_frm/thread/078a7d3734e1bb95#

Post #4 appears in the tree view but not in the message view in Google Groups.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
That doesn't sound like the same problem.  That sounds like just a bug in Groups not specific to us.  Which I hate to say it, should get reported to them and not us.  We don't have any service level agreement with them beyond getting newsgroups created, so my complaints to them about something of that nature probably won't go any further than yours would.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
(Reporter)

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.