If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Search Bar no longer works after windows changes state between online and offline when application data folder is redirected

RESOLVED DUPLICATE of bug 364957

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 364957
11 years ago
9 years ago

People

(Reporter: John Guttridge, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Search toolbar becomes totally inert when windows changes either from offline to online or from online to offline when the users application data folder has been redirected to a network location. For example, If I am connected to the office network and working online (windows) and I open a browser window search works just fine. I then undock my laptop and go connect to another network, search bar becomes inert. Additionally, if I am already offline and I bring my laptop back to the office network and allow windows to synchronize the search bar becomes inert. The search bar works as expected in either state as long as you have not changed between online and offine while the browser is running. If you close the browser and reopen it the search bar works again. 

Reproducible: Always

Steps to Reproduce:
1. configure your user account to use redirected folders on the application data folder and redirect to a network share. Make files in the application data folder available offline.
2. start a browser and test search
3. change state between online and offline.
4. test search, it should now be inert.

Actual Results:  
Search bar was intert

Expected Results:  
search bar should still work
Could you set browser.search.log and javascript.options.showInConsole to "true" using about:config, and paste any relevant Error Console output after performing the steps to reproduce? That might help narrow down the problem.
This should be a dupe of bug 364957.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 2.0 Branch
Duplicate of bug: 364957
You need to log in before you can comment on or make changes to this bug.