Select box with size set when set to hidden keeps scroll bar.

RESOLVED DUPLICATE of bug 187435

Status

()

RESOLVED DUPLICATE of bug 187435
11 years ago
9 years ago

People

(Reporter: steven.s.elliott, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Max OS X FF 2.0.x (ONLY)
When a SELECT box has a size set and then is the visibility is set to hidden will continue to display a scrollbar.  The linked URL when viewed with FF on OS X if you click on an option in a the select list will hide the options but the scrollbar remains.

I have modified the test file for Bug 376607 but this but this bug has nothing to do with that bug other than they both concern the SELECT element.


This problem is not seen on SeaMonkey (1.0.6) on OS X.





Reproducible: Always

Steps to Reproduce:
As described in the details section.
Actual Results:  
SELECT options disappear but the scrollbar remains.

Expected Results:  
Scrollbar should disappear as well.
(Reporter)

Comment 1

11 years ago
Created attachment 264761 [details]
test case

Comment 2

9 years ago
This was resolved in the Firefox 3 release.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 187435
You need to log in before you can comment on or make changes to this bug.