Closed Bug 38105 Opened 22 years ago Closed 22 years ago

"sortkey" of "Future" milestone should be below m30's

Categories

(mozilla.org :: Miscellaneous, task, P2)

Other
Other

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jruderman, Assigned: leger)

References

Details

the "target milestone" list now includes a "future" option.  this option should 
be below m30, not above m1.

(is this "webtools/bugzilla" or "mozilla.org/something"?)
*** Bug 38477 has been marked as a duplicate of this bug. ***
Does "future" mean "probably more than a few milestones off", or does it 
mean "probably after Netscape 6"?
It means "after Mozilla 5.0". It is exactly equivalent to the old "LATER"
resolution.

The simple and quick solution is to rename it "future" (lowercase) or "MFuture" 
or anything else which will appear after "M30" when sorted alphabetically.
Thus, reassigning to Mozilla.org product.

Increasing priority as this makes the "Future" milestone unusable at the moment.
Assignee: tara → mitchell
Severity: normal → major
Component: Bugzilla → Miscellaneous
Priority: P3 → P2
Product: Webtools → mozilla.org
Jan, I think this is yours, isn't it?
Assignee: mitchell → leger
Changing product to WebTools.

Component: Miscellaneous → Bugzilla
Product: mozilla.org → Webtools
Reassigned to Bugzilla's owner.
Assignee: leger → tara
I think we need a better name than "Future" as well, to reduce ambiguity.  
Maybe "after NS6", or "after Mn" if we know at this point which milestone will 
correspond to Netscape 6.0.
The bug I filed (bug 38477) was about displaying the "Future" bugs last in the 
bug lists sent as a response to a Bugzilla query. This bug is about displaying 
the "Future" item last in the "Target Milestone" popup menu (although the bug 
description makes it clear that the reporter expected the same thing as I did).
Are those equivalent?  If I sort the list of bugs I reported by resolution, 
they end up in the same order as the resolutions on query.cgi except that not-
resolved bugs are at the top of the sorted list and at the bottom of listbox on 
query.cgi.
Jesse: Bugzilla Milestones represent MOZILLA's schedule, not NETSCAPE's
schedule. So "NS6" is not relevant to the Bugzilla milestone field.

Pierre: The sorting, in both cases, is done alphabetically. There is not much
that Bugzilla can do about it -- the Milestones field data is filled in by 
Jan Leger, and can include anything, such as "M1", "M30", "Future" or "Zappa".
So the solution is to change the content of the field _as_installed_at_the_
_Mozilla.org_site_, not change the default configuration of Bugzilla, which is
what tara would do.
Assignee: tara → leger
Component: Bugzilla → Miscellaneous
Product: Webtools → mozilla.org
If they are sorted alphabetically, why is M2 before M12?  According to bug
#7782, this should be fairly easy to fix without a milestone name change.
Do'H! In that case, it's even easier than changing the name. All we need to do 
is change the sort key for the "Future" milestone!
Summary: "future" milestone should be below m30 → "sortkey" of "Future" milestone should be below m30's
guys..I can change this is you want...does it really matter that much?  Moving 
it is easy, but I have to plan way out for placement, and if others move their 
milestones on other products Future couls again display else where...

If is really bugs ya, I'll go change it.  Having it at the top for now helps get 
people to Use it :-)
Well, actually, having it at the top is currently _preventing_ people (well,
Pierre, at least) from using it. 

See his comment from bug 38477:
> When I display my bug list, the "Future" bugs are listed just after the "New" 
> bugs and before all the bugs that already have a target milestone. It would
> be nice if the "Future" bugs were displayed last on the list, thus avoiding 
> some noise on the first page.

...and on bug 38447:
> [...] I prefer Later because the bugs don't appear on top of my list. I 
> understand that it can make them harder to find but I don't have a lot of 
> them and I don't think I ever received a dup for any of these, so I prefer to 
> mark them Later and avoid the noise. I may change my habits if bug [38105]
> gets fixed (or if you give me a compelling reason :-).

[cc'ing pierre out of courtesey]
Jan- As we get closer to the final release, we'll have more and more of these 
"Future" bugs, meaning that the top of the lists will squatted by all the bugs we 
are so frustrated about because we can't kill'em before the deadline, instead of 
showing up-front the P1s we are so glad to run after. Really, this simple change 
can do a lot to reduce the volume of stress.
This has been fixed for a couple of weeks -- Dawn changed the sortkey of the 
query so if you sort by Milestone Future ends up at the bottom.
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
Verif fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.