Closed Bug 381244 Opened 14 years ago Closed 14 years ago

Can't close or cancel a master password dialog (needs multiple clicks)

Categories

(Toolkit :: Password Manager, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 267807

People

(Reporter: ria.klaassen, Unassigned)

References

Details

(Keywords: regression)

Spin-off from bug 381164.

Steps to reproduce:
- Make a profile with passwords in it (copy a signons2.txt and key3.db to the new profile)
- Set a master password
- Restart Firefox and go to a login site with a remembered password
- When the master password dialog pops up, try to close it with the Cancel or Close button

Actual result: doesn't succeed.

Two regression ranges where this could have happened according to http://hourly-archive.localgho.st/ are:

http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1179305220&maxdate=1179313139
and http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1179313140&maxdate=1179327719
Actually the close does succeed.  The cancel button does dismiss the window and it disappear from the screen.  The problem is that as soon as you close the window, the browser decided to prompt for the Master Password again, so the window re-appears.
Summary: Can't close or cancel a master password dialog → Can't close or cancel a master password dialog (needs multiple clicks)
Bug 381164 comment 7 says that the dialog appears once for every saved password, which is potentially a large number.
It's even double: I need to click 76 times "Cancel" for 38 passwords.
Blocks: 381266
Closing that dialog by clicking "Cancel" multiple times completely disabled my ability to autofill passwords or view saved passwords.

After clicking "Cancel" 82 times to close the Master Password dialog, I navigated to the Yahoo login page (where I have a saved password); the Master Password dialog didn't appear. Opened the Password Manager, the list of sites and usernames was displayed as normal; clicked "Show Passwords" and got the Master Password dialog as normal - but after the Master Password was entered, no passwords or usernames were displayed, just the list of sites. Went back to the Yahoo login page, the password was not filled in. Restarting Minefield restored everything to the previous condition, with the Master Password dialog appearing when not needed.
I'm duping this back into 381164, as it turns out these issues are more related than I initially thought. Sorry Ria. :-)
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 381164
Not a dupe of bug 381164. You won't get ask for each stored password but for each request. This is handled in bug 267807.
Duplicate of bug: 267807
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.