js warnings on start of Firefox brought up by places

VERIFIED FIXED in Firefox 3 alpha5

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
11 years ago
8 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 3 alpha5
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a5pre) Gecko/20070520 Minefield/3.0a5pre

On trunk I'm not able to add any Live Bookmark. Following js warning are visible by starting Fx and trying to add a Live Bookmark:

Warning: trailing comma is not legal in ECMA-262 object initializers
Source File: chrome://browser/content/browser.js
Line: 273
Source Code:
}; 

Warning: trailing comma is not legal in ECMA-262 object initializers
Source File: chrome://browser/content/browser.js
Line: 273
Source Code:
}; 

Warning: function PC_setBookmarksToolbarFolder does not always return a value
Source File: chrome://browser/content/places/controller.js
Line: 968, Column: 2
Source Code:
  }, 

Warning: trailing comma is not legal in ECMA-262 object initializers
Source File: chrome://browser/content/places/treeHelpers.js
Line: 295
Source Code:
}; 

Warning: reference to undefined property this._anno
Source File: chrome://browser/content/places/toolbar.xml
Line: 218
(Assignee)

Comment 1

11 years ago
Created attachment 265426 [details] [diff] [review]
Patch v1.0 removes js warnings
Attachment #265426 - Flags: review?(mano)
(Assignee)

Updated

11 years ago
Blocks: 296661
Comment on attachment 265426 [details] [diff] [review]
Patch v1.0 removes js warnings

r=mano
Attachment #265426 - Flags: review?(mano) → review+
Target Milestone: --- → Firefox 3 alpha5
mozilla/browser/base/content/browser.js 1.789
mozilla/browser/components/places/content/bookmarkProperties.js 1.50
mozilla/browser/components/places/content/controller.js 1.151
mozilla/browser/components/places/content/toolbar.xml 1.84
mozilla/browser/components/places/content/treeHelpers.js 1.6
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
(Assignee)

Updated

11 years ago
Status: RESOLVED → VERIFIED
> On trunk I'm not able to add any Live Bookmark.

can you elaborate on what happens?  

Do you not get the "Add Live Bookmark" dialog?

Or you do, but adding it does nothing?

(Let's spin this off to another bug.)
(Assignee)

Comment 5

11 years ago
Seth, that was strange. At first I haven't seen that dialog and no Live Bookmark was added. But after removing all this warnings and reversing the changes I always can see that dialog. I don't know if something has been changed on my database that it works now. Sorry, but I cannot reproduce it anymore.
Henrik, thanks for the response.  See bug #380232, where occasionally I haven't see the Live Bookmark / Add Bookmark dialog.  Note, it is intermittent.  Could that be what you saw?
(Assignee)

Comment 7

11 years ago
Lets move over to that bug. Seth, I already commented there.
Duplicate of this bug: 381347
browser/components/places/content/toolbar.xml 1.85 for PlaceUtils -> PlacesUtils
verified with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a7pre) Gecko/2007070504 Minefield/3.0a7pre
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.