Open "livemark name" ignores middle click

VERIFIED FIXED in Firefox 3 beta3

Status

()

P3
normal
VERIFIED FIXED
12 years ago
9 years ago

People

(Reporter: pablo, Assigned: mak)

Tracking

Trunk
Firefox 3 beta3
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070521 Minefield/3.0a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5pre) Gecko/20070521 Minefield/3.0a5pre

When middle clicking the menuitem Open "livemark name", menu is dismissed and firefox does nothing. Ctrl+Left click works as expected opening a new tab.

Reproducible: Always

Steps to Reproduce:
1.Open any livemark
2.Middle Click on Open "livemark name"
Actual Results:  
Nothing happens

Expected Results:  
Livemark url should open in a new tab
Confirmed that it doesn't open in a new tab.
Component: Places → RSS Discovery and Preview
QA Contact: places → rss.preview
Back to Places - RSS D&P just handles the feed, it doesn't create a bookmark menu and click handlers from it.
Component: RSS Discovery and Preview → Places
QA Contact: rss.preview → places
Thanks for the explanation. I always wondered; it seemed inconsequent.
(Assignee)

Comment 4

11 years ago
related to bug 328686?
(Assignee)

Updated

11 years ago
Duplicate of this bug: 394555
Duplicate of this bug: 395392
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
(Assignee)

Updated

11 years ago
Duplicate of this bug: 404522
(Assignee)

Comment 8

11 years ago
Created attachment 293249 [details] [diff] [review]
intercept middle-click with onclick

the middle-click is usually served in BT_onClick, but we need to call the onCommand handler of the item as target.onCommand(event). this is not possible due to Bug 246720, so this can be addressed using checkForMiddleClick in the onClick attribute of the element.

Notice that now middle-clicking this item will open all feed items in tabs, that is clearly not the expected behaviour, the user wants really to open the feed url in a new tab, while he ends up with a dialog asking if he really wants to open N tabs...
Attachment #293249 - Flags: review?(mano)
(Assignee)

Updated

11 years ago
Flags: blocking-firefox3?

Updated

11 years ago
Flags: blocking-firefox3? → blocking-firefox3+
Priority: -- → P3
Target Milestone: --- → Firefox 3 M11
Comment on attachment 293249 [details] [diff] [review]
intercept middle-click with onclick

> // If a user middle-click this

middle-clicks.

r=mano.
Attachment #293249 - Flags: review?(mano) → review+
Assignee: nobody → mak77
Keywords: checkin-needed
Checking in browser/base/content/browser-places.js;
/cvsroot/mozilla/browser/base/content/browser-places.js,v  <--  browser-places.js
new revision: 1.76; previous revision: 1.75
done
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre)
Gecko/2007121805 Minefield/3.0b3pre 
Status: RESOLVED → VERIFIED
Duplicate of this bug: 409159
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.