Stored Form Data dialog is losing its focus when adding a second new field name

VERIFIED DUPLICATE of bug 39795

Status

SeaMonkey
Preferences
P3
critical
VERIFIED DUPLICATE of bug 39795
18 years ago
14 years ago

People

(Reporter: Daniel McAuliffe, Assigned: matt)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
BuildID:    2000050308
Platform Win98

The Stored Form Data dialog from Preferences|Advanced|Forms and Passwords|View 
Saved Data is losing its focus when adding a second new field name.  Also when 
the dialog does lose its focus and only the add new form prompt is visible if 
the cancel button is pressed and then the cancel button of the Stored form 
dialog is pressed Mozilla is hanging.  

Reproducible: Always
Steps to Reproduce:
1. Have both Mozilla and another application (eg IE5 both maximised) and then 
open the Stored Form Data from Preferences|Advanced|Forms and Passwords|View 
Saved Data
2. Click on Add New....  Prompt dialog should appear.  Just click on OK to 
close propmt. 
3. Click on Add New..... again.  This Stored Form Data dialog loses its focus 
and goes behind the browser.
4. Click on the cancel button to return the Stored Form Data dialog to the 
front of the screen. Now click cancel to close this dialog and you find the 
other application that is maximised come to the front.  As soon as Mozilla is 
re-selected both the dialog open and browser hang.

Actual Results:  Both browser and dialog are hanging.

Expected Results:  Stored Form Data dialog should never have been sent to the 
back in the first place and both the dialog and browser shouldn't hang.
Confirming on 20000518 W95. Slightly different steps to reproduce:

Edit |Preferences | Advanced | Forms and Passwords | View Saved Data... | 
Add New... | Cancel | Cancel.

Mozilla places itself second in the window stack. I believe this may be a known 
issue, but I can't find the bug number. When you bring it back to the front, the 
Forms and Passwords page of the preferences is open, but neither it nor the rest 
of the browser is accepting input.

Not that this bug does not occur if you access the View Stored Form Data field 
via Tasks | Privacy and Security | Form Manager | View Stored Form Data.

This leads me to guess that the View Stored Form Data form might assume it is a 
direct child of the browser, or something like that. When accessed via 
preferences, it isn't, and the Preferences window gets left in limbo. The rest 
of the browser is waiting for it to shut and so doesn't accept input either.

CCing morse@netscape.com, as this might well be a single signon problem (I 
believe that component owns this dialog).

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
No, it's not a single signon thing -- it's a prefs thing.  In fact it's a dup of 
39795 which in turn is a dup of 39205.  So there are some serious problems with 
the pref panel.

*** This bug has been marked as a duplicate of 39795 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Daniel, is this still a problem for you with a recent build? am verifying this
one otherwise...
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.