No indication of attachment when a mail consiststs only of and inline attachment

NEW
Unassigned

Status

11 years ago
7 years ago

People

(Reporter: raanan, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: version 2.0.0.0 (20070326)

When a mail content is only composed of an attachment with Content-Disposition: inline and with View/Display Attachments Inline unselected, the mail body is empty and there is no indication of attachments. 

The user only sees the header and an empty mail panel.

Happened to me with a Delta airlines confirmation.

Reproducible: Always

Steps to Reproduce:
1. create a mail with the structure below and send it
Content-Type: multipart/mixed; 
	boundary="----=_Part_8956_16086539.1179511753252"

------=_Part_8956_16086539.1179511753252
Content-Type: text/html
Content-Transfer-Encoding: base64
Content-Disposition: inline; filename=Body.html

(Coded text goes here)

------=_Part_8956_16086539.1179511753252--

2. unselect View/Display Attachments Inline
3. select the incoming mail
Actual Results:  
the mail panel displays the header area and an empty mail panel

Expected Results:  
Indicate that there is an online attachment (activate View/Display Attachments Inline)

Updated

11 years ago
Summary: No indication of attachment → No indication of attachment when a mail consiststs only of and inline attachment
Version: unspecified → 2.0

Updated

10 years ago
Assignee: mscott → nobody

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 273793

Comment 2

9 years ago
Aureliano, I don't think this is a dupe -- the MIME structure described here does not match the structure from the testcase at the other bug.
(In reply to comment #2)
> Aureliano, I don't think this is a dupe -- the MIME structure described here
> does not match the structure from the testcase at the other bug.

Set as Unconfirmed per comment #2

;-)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
dup of bug 182627?
(In reply to comment #4)
> dup of bug 182627?

It seems: I agree. Mike?

Comment 6

9 years ago
Actually, I think it's bug 229075.

Comment 7

8 years ago
I have received exactly this kind of email from Delta airlines and have the same problem.

If I have "Display attachments inline" unchecked, the message body is completely blank and there is no indication at _all_ that there is an attachment with this email.

In general I don't want to show attachments inline and there should be something in the message header area that indicates there are attachments not displayed -- there should be a list of the attachments and I should be able to open them each individually.

Comment 8

8 years ago
Confirming Doug's observation that with "Display Attachments Inline" unchecked, message is blank and no indication of an attachment for "Content-Disposition: inline" parts.  Unlike the bug reports suggested as possible dups, this occurs even if the "filename=" parameter is not present, so this appears to be a regression from previous versions of TB.

RFC2183, section 2.1 says "inline" data should be displayed to the user "automatically upon display of the message".  Even if that doesn't happen, I'd agree with Doug's further comment that if the content is NOT displayed, there should be some indication that there is additional data, and some method of choosing to display (or not) that data.

Changing status to "NEW".
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

7 years ago
I experience the problem of a message with no body displayed when receiving Craigslist posting confirmation emails.  My default setting for "View | Message Body As" is "Original HTML".  When I change this setting to "Plain Text" I can see the body of the message.  However, I do not want all emails to be displayed as plain text.  Having read D. Hockin's and M. Pasek's posts on another site, I agree that this is not a duplicate of another bug.  
Windows XP Professional Version 2002 SP3
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.17) Gecko/20110414 Lightning/1.0b2 Thunderbird/3.1.10

Comment 10

7 years ago
This problem occurs with many official craigslist emails read in Thunderbird as HTML.  They can be viewed okay as Plain Text, and if Display Attachments Inline is selected they are also viewable.   User should not be forced to either of those workarounds --- is this a defect in craigslist email structure or TB handling of multipart messages?  types of email showing as blank:   password reset request, post confirmation email, forum subscription post emails, post/edit/delete verification emails ...

Mac OSX, TB 3.1.17

Comment 11

7 years ago
I have a similar problem with a user who sends me screenshots. I have inline display of attachments disabled, too, and see empty emails.

I attach a partial header listing and a screenshot, indicating the message structure. The payload is in the PNG image.

Comment 12

7 years ago
I have a similar problem with a user who sends me screenshots. I have inline display of attachments disabled, too, and see empty emails.

I attach a partial header listing and a screenshot, indicating the message structure. The payload is in the PNG image.

This is the latest TB under Linux, btw.

Comment 13

7 years ago
Created attachment 586726 [details]
screenshot indicating the message structure

Comment 14

7 years ago
Created attachment 586727 [details]
partial headers for the message shown in the screenshot
You need to log in before you can comment on or make changes to this bug.