Address-Field in MailNews Compose Window not working properly

RESOLVED FIXED in mozilla1.9alpha5

Status

MailNews Core
Composition
--
major
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: Tobias Fischer, Unassigned)

Tracking

({regression})

Trunk
mozilla1.9alpha5
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [This bug is now a meta: use it only to file dependent bugs.])

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 265650 [details]
Screenshot from Address-Window

After yesterdays checkin for Bug 380872 and Bug 53901 the Adress-Fild in MailNews Compose-Window was cut off at right. Asrail has described this before in https://bugzilla.mozilla.org/show_bug.cgi?id=380913#c17 
Screenshot coming up soon. 

So this issue might be an Duplicate to Bug 380913, but I prefer to file a new one for a new issue.
This isn't a duplicate, since it's another issue.

It's even worse... this bug won't be fixed along-side with bug 380913 ;).


Thanks for filling this Tobias.
Status: UNCONFIRMED → NEW
Ever confirmed: true
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/2007052204 SeaMonkey/1.5a] (suiterunner, tinderbox-builds) (W2Ksp4)

A patch from bug 380872 fixed bug 380913;
it seems another patch there will fix the current bug too.
Assignee: mail → nobody
Blocks: 53901
Severity: normal → major
Component: MailNews: Main Mail Window → MailNews: Composition
Depends on: 380872
Keywords: regression
Product: Mozilla Application Suite → Core
QA Contact: composition
Summary: Address-Field in MailNews Compose Window cut off at right (Regression) → Address-Field in MailNews Compose Window cut off at right
Target Milestone: --- → mozilla1.9alpha5

Comment 3

11 years ago
Apart from the blank area on the right the address widget now says 'To:' also when replying to a 'Newsgroup:'. Can be seen in the screen shot above as well.

Comment 4

11 years ago
Also there is a problem with the auto filling of addresses which has become very narrow and difficult to handle. It is different from the previous full working versions up to 20070514

Comment 5

11 years ago
I don't understand why, after changes had been made that caused bug 380372 and this, the work done in the update that caused it wasn't reversed until it was more stable.  Bug 380372 caused Thunderbird to completely lose functionality.  The current bug is, to say the least, a nuisance.
I agree that it "should" have been.
Yet, Jonas is actively working to fix the issues, then let's give him some time.
(As a "user", use a previous/working nightly, until the reported bugs are fixed.)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/2007052300 SeaMonkey/1.5a] (suiterunner, tinderbox-builds) (W2Ksp4)

Status update:
The cut off in the middle of the area is gone :-)
But, now, the To/Cc/... dropdown uses like 80% of the area width :-|
More regressions.

In addition to the large white space, it seems that when doing a reply-all
all the addressees are now listed in the addressee pane as To: recipients,
no Cc: recipients.  

If you click on the button that says To: and select Cc:, it doesn't change.
It remains To:

If you click on that button again and select Reply-To: it changes to Reply-To
and the button gets wider.  When that happens the white area gets smaller. 

Once changed to Reply-To:, it can thereafter be successfully changed to Cc:

I have one email account setup to Bcc me on all outgoing emails. 
With this new set of regressions, the Bcc address comes up as a To: 
address, not as a Bcc:.  
Flags: blocking1.9?
Duplicate of this bug: 381696
Summary: Address-Field in MailNews Compose Window cut off at right → Address-Field in MailNews Compose Window not working properly
Depends on: 381722
Depends on: 381723
For quite long this one has become a meta-tracker.

File new issues for new issues and mark as blocking this one.

They're likely issues, but as you may see, fixing one does not mean that the other will be fixed too, even if the cause is the same.

So... it's good to keep track of each of them (sizing and labeling are two unlikely things, so... different bugs).


Comment here about the bug if you can't mark it as blocking this one and someone will do.

Comment 11

11 years ago
Guys, I think everyone needs to chill until the latest patch in bug 380872 lands. Then we can reevaluate whether this is still a problem.
We should keep track of the issues.

Bug 380872 is already marked as a dependency of this bug, so it means we will be aware when its status change (so we'll check and see if the other bugs still happen).



Hardware: PC → All

Comment 13

11 years ago
Address field still bumped way over to the right (as described by Serge above) in version 3.0a1pre (20070524)

Updated

11 years ago
Depends on: 382083
I'm now running the 20070525 build.  
The big white area in the address fields is gone.               (good)
The width of the To/CC/Reply-To/etc buttons is now reasonable.  (good)
All the buttons still say "To:"               :(
This is a net improvement over 20070522.  
Almost, but not quite, as good as 20070418 in mail composer.
Blocks: 380872
No longer depends on: 380872
(In reply to comment #14)
> Almost, but not quite, as good as 20070418 in mail composer.

Thanks for the confirmation, but pay attention:
*all these are already known and dependent bugs have been opened for each different issues.
*"This" bug is fixed, code-wise; but remains open only because it "morphed" to a meta bug.


Removing 'nelson: blocking1.9 ?', which is no longer needed,
since Boris moved bug 380872 (which has "blocking1.9 +") from 'Depends on' to 'Blocks'.
Flags: blocking1.9?
Whiteboard: [This bug is now a meta: use it only to file dependent bugs.]
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a5pre) Gecko/2007053102 SeaMonkey/2.0a1pre] (nightly) (W2Ksp4)

R.Fixed, as all blockers are now fixed.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.