A suggestion: „Save session“

RESOLVED DUPLICATE of bug 351774

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 351774
11 years ago
11 years ago

People

(Reporter: klaidas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Hello, 

When I'm browsing the internet, I usually have about 15-20 tabs open, and sometimes more. Those are sometimes links I'd like to/should read, or what I need at that moment. However, there is a problem: if I want to shut down/restart/etc the computer, or just close firefox for now BUT be able to open those tabs later, I have to either bookmark them all to some folder or kill firefox manually (ctrl+alt+del/kill -9/etc), so that I can *restore* the session later.

How about having an option to „Save current session“, so that people like me could avoid doing such workarounds?

Reproducible: Always

Steps to Reproduce:
1. Open a lot of tabs with interesting information
2. Decide to go away from the PC
3. Understand that you now have to kill Firefox/bookmark everything for further browsing
4. Comment on the bug


Expected Results:  
Have a „Save session“ button :)

Comment 1

11 years ago
Have you already discovered the setting
Tools -> Options -> Main -> Startup -> When Firefox starts:
-> "Show my windows and tabs from last time"?

That functionality might get even better exposed once bug 351774 is fixed.

There's certainly also a bug about full fledged session saving (though that's got some probability for having been WONTFIXED)...
(Reporter)

Comment 2

11 years ago
Yes, but that's more like the default behavior in Opera. 

Instead of just reopening pages which were open when closing the browser, I'd suggest to have a choice of either: just closing everything; saving the current session and closing firefox; canceling;
(Reporter)

Comment 3

11 years ago
But yeah, that pretty much what bug 351774 is about :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 351774
You need to log in before you can comment on or make changes to this bug.