Closed Bug 381734 Opened 15 years ago Closed 13 years ago

a better 404 page could be created for pre versions

Categories

(www.mozilla.org :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 491731

People

(Reporter: ray, Assigned: reed)

References

Details

(Keywords: helpwanted)

Attachments

(2 files)

Every time I launch an early version of Firefox, it sends me to a page such as:

http://www.mozilla.org/projects/firefox/3.0a5pre/whatsnew/

This page has very generic, not very helpful information. It occurred to me that m.org actually controls this page, so there could be more appropriate information for URLs that clearly follow this format.

For example: "You may be using a pre-release version of the browser. If so, thanks for helping us test. Please go to litmus.mozilla.org for more information on testing."

This would certainly be more helpful than "Please check your spelling and punctuation."
OS: Mac OS X → All
Hardware: PC → All
Product: mozilla.org → Websites
We're getting several bug reports each week about this and updating the 404 page for this sounds like a great idea.  Reed, would this be something relatively easy to do?
Something like I did in
https://doctor.mozilla.org/?file=seamonkeyproject-org/src/releases/.htaccess
for SeaMonkey sounds good, redirecting all users of *pre versions to our "get involved" page instead.
I like that idea! I'd say redirect it to m.o/projects/minefield but that's already a page that opens. Do we have another page we could send users to?
(In reply to comment #1)
> We're getting several bug reports each week about this and updating the 404
> page for this sounds like a great idea.  Reed, would this be something
> relatively easy to do?

You wouldn't be updating the 404 page, per se. We would just create a generic page and redirect pages to it.
As discussed in the www.mozilla.org planning meeting today, I'm assigning this bug to Reed to redirect the Firefox pre URLS to

http://www.mozilla.org/contribute/

We may decide to create a specific page for use in the future, but pointing to the Contribute page is a good short term fix.
Assignee: nobody → reed
Duplicate of this bug: 467273
Duplicate of this bug: 473264
Duplicate of this bug: 478838
This patch adds a redirect in the style of the one I have added in SeaMonkey, using a temporary redirect so that browser re-check if we change it to maybe something more fitting sometime.
Attachment #362826 - Flags: review?(reed)
Comment on attachment 362826 [details] [diff] [review]
redirect in the style of SeaMonkey

Should use a RewriteRule with a RewriteCond that checks if the directory exists so that both pre and other versions like 3.1a1 can be handled appropriately for those who build with unofficial branding. Also, .* may be a little overboard... I try to be more restrictive in my matching.
Attachment #362826 - Flags: review?(reed) → review-
Duplicate of this bug: 480152
Duplicate of this bug: 480678
Duplicate of this bug: 484118
Keywords: helpwanted
We've posted some stats to get a better sense of the scale of this issue.  See the Top 404 Errors tab at:

http://spreadsheets.google.com/ccc?key=rL83qEekHMrV0kk0g9hCujA

For instance, in May there were just under 50,000 errors generated for the non-existant page at /projects/firefox/3.6a1pre/whatsnew/ .  That's just one of the Firefox pre related pages generating errors.
Attached file Draft pre-release page
It looks like we never really identified where users should get redirected to, so I'm attaching a draft of a proposed new pre-release page that would live at www.mozilla.org/projects/firefox/prerelease.html

This is based off of the existing Minefield page -- I rewrote the intro to make it relevant to pre-release users and removed Minefield from the text below.  Someone more familiar with QA should check the bottom half to make sure that's the information we would want to include here.
Well, I just have one word for the page you are proposing. Wow! Really. It looks great and it has got everything one would need. I think this will help with the sometimes daunting task (for newbies) of familiarizing oneself with the Mozilla infospace.

Thanx - ray
Comment on attachment 381347 [details]
Draft pre-release page

Sam, could you take a look at this draft page and see if there is anything we should change?
Attachment #381347 - Flags: review?(samuel.sidler)
Comment on attachment 381347 [details]
Draft pre-release page

r=me

This looks fine to me.
Attachment #381347 - Flags: review?(samuel.sidler) → review+
What about the script that includes a user agent string.  It looks like it is using something from Minefield and I wasn't sure how relevant that was for this page.

  <input name="useragent" id="useragent" value="Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008032504 Minefield/3.0b5pre" type="hidden">
Re comment #19, after talking to Sam it looks like that user agent string is just a default value if the script can't get the real one.  It seems like this is fine then, so I just checked in the page and it should be live soon at:

http://www.mozilla.org/projects/firefox/prerelease.html
Redirects for pre-release URLs are being dealt with in bug 491731.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 491731
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.