Closed Bug 381775 Opened 16 years ago Closed 16 years ago

"Wrong parent style context" clicking <select>

Categories

(Core :: Layout, defect)

x86
macOS
defect
Not set
minor

Tracking

()

RESOLVED FIXED

People

(Reporter: jruderman, Unassigned)

References

Details

(Keywords: regression, testcase)

Steps to reproduce:
1. Open a Mac trunk debug build.
2. Load data:text/html,<select><option>X
3. Click the select.

Result: a bunch of output like

frame: Text(-1) (0x268f504) style: 0x268f458 :-moz-non-element {}
Wrong parent style context:  style: 0x268f368 :-moz-display-comboboxcontrol-frame {}
should be using:  style: 0x26c2ff0 {}

frame: Text(-1) (0x268f5b8) style: 0x268fa9c :-moz-non-element {}
Wrong parent style context:  style: 0x268f90c :-moz-button-content {}
should be using:  style: 0x268f710 {}

This might be a regression from enabling Aqua-looking form widgets on Mac.
I definitely don't see this with a May 18 build.  So a regression since then?
Keywords: regression
I think this only happens when native theming is enabled for HTML form controls, making it a regression from bug 175279.
Blocks: 175279
This looks like the same thing as bug 380116, but I don't have a way to verify right now.

Bug 175279 probably just made clicking a select do a reresolve on it, which may be a bug in its own right -- restyling all those options would be expensive, and I don't see anything in the appearance changing...  Might want to get that filed on Cocoa widget.
Depends on: 380116
I can no longer reproduce this bug on trunk.

--> FIXED by the checkin to bug 380116.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.