Note: There are a few cases of duplicates in user autocompletion which are being worked on.

reftest 346774-1a.html fails with native form controls on Mac OS X (border of <select size="1">)

RESOLVED FIXED

Status

()

Core
Layout
RESOLVED FIXED
10 years ago
5 years ago

People

(Reporter: Josh Aas, Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Reftest 346774-1a.html fails with native form controls on Mac OS X. Frustratingly, when I render the document, take a screenshot, then render the reference document, take a screenshot, and compare the two using an automated tool, every pixel is exactly the same.

The data URLs in the reftest do not match though, and when they are loaded the image looks crazy. This may be a problem with the png encoder.
(Reporter)

Comment 1

10 years ago
Same thing for reftest 346774-1b.html
(Reporter)

Comment 2

10 years ago
Same thing for reftest 346774-1c.html
More likely a problem with the painting code than the PNG encoder.

Could you attach something containing the data URLs so others can look?  (For example, the HTML resulting piping the relevant segment of reftest output through mozilla/layout/tools/reftest/clean-reftest-output.pl ?)
(Try putting the form controls inside a <div style="opacity:0.5"> ... </div> and see if you get similar problems.)
Created attachment 266096 [details]
reftest output snippet
Blocks: 175279

Updated

10 years ago
Summary: reftest 346774-1a.html fails with native form controls on Mac OS X → reftest 346774-1a.html fails with native form controls on Mac OS X (border of <select size="1">)

Updated

10 years ago
Depends on: 385298
Seems to have been fixed by bug 382092.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.