Closed Bug 381831 Opened 16 years ago Closed 10 years ago

reftest 346774-1a.html fails with native form controls on Mac OS X (border of <select size="1">)

Categories

(Core :: Layout, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: jaas, Unassigned)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

66.05 KB, text/html; charset=us-ascii
Details
Reftest 346774-1a.html fails with native form controls on Mac OS X. Frustratingly, when I render the document, take a screenshot, then render the reference document, take a screenshot, and compare the two using an automated tool, every pixel is exactly the same.

The data URLs in the reftest do not match though, and when they are loaded the image looks crazy. This may be a problem with the png encoder.
Same thing for reftest 346774-1b.html
Same thing for reftest 346774-1c.html
More likely a problem with the painting code than the PNG encoder.

Could you attach something containing the data URLs so others can look?  (For example, the HTML resulting piping the relevant segment of reftest output through mozilla/layout/tools/reftest/clean-reftest-output.pl ?)
(Try putting the form controls inside a <div style="opacity:0.5"> ... </div> and see if you get similar problems.)
Blocks: 175279
Summary: reftest 346774-1a.html fails with native form controls on Mac OS X → reftest 346774-1a.html fails with native form controls on Mac OS X (border of <select size="1">)
Depends on: 385298
Seems to have been fixed by bug 382092.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.