Closed Bug 382224 Opened 15 years ago Closed 15 years ago

Content of message appears in accName property of list items in message list

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows Vista
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mick, Assigned: mscott)

References

(Blocks 1 open bug)

Details

(Keywords: access)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/20070526 Minefield/3.0a5pre
Build Identifier: Mozilla/5.0 (Windows;U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/20070526 Thunderbird/3.0a1pre ID:2007052603 [cairo]

On some list items in the message list, the accName for MSAA is made up of subject, from etc, but also contains the entire text of either the message in question, or an entirely unrelated message. It seems to only happen when this message text is below a certain size. Very large messages do not seem to place their text in the name this way. This problem doesn't seem to happen if there are a small amount of messages in the list, but with mine having over 40, the problem is happening.  

Reproducible: Always

Steps to Reproduce:
1. Start a screen reader that relies heavily on MSAA such as NVDA 0.5 [www.nvda-project.org] or Narrator.
2. Start Thunderbird 3 alpha (latest-trunk), see above build ID
3. Move focus to the message list and arrow up and down, listening to the names of the items.
Actual Results:  
For some mesages, the actual text of the message, or another unrelated message, will be part of the item name.

Expected Results:  
The text of the message should not be in the item name, since this drasticly increases the amount of information the user has to read for each item.
Version: unspecified → Trunk
Should be because of the semi-functioning bug 364090.
Blocks: 364090
For now this bug can be closed as  the problem no longer happens since the   preview text feature talked about in bug 364090 has been disabled. However, if the feature was reenabled, The accessibility of Thunderbird's message list would really have to be reconsidered to either:
1. make it possible to reorder the columns via the keyboard,
2. Append column names in to the accessible text of each list item, or
3. Change the message list in to a table with accessible colums 
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Keywords: access
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.