Last Comment Bug 382300 - work offline checkbox in Thunderbird profile manager has no effect
: work offline checkbox in Thunderbird profile manager has no effect
Status: RESOLVED WORKSFORME
: regression
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: 2.0
: x86 Windows XP
: -- normal with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-29 02:54 PDT by Eric Moore
Modified: 2008-08-14 07:33 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Eric Moore 2007-05-29 02:54:27 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: version 2.0.0.4pre (20070528)

The "work offline" checkbox in the Thunderbird profile manager doesn't seem to have any effect when you launch Thunderbird from the profile manager. If you set  that checkbox, exit, and then launch Thunderbird normally it also doesn't have any effect. If I run the profile manager again that checkbox is unchecked, so it doesn't seem to be sticky. 

This problem occurs with both with the 2.0 release and the version 2.0.0.4pre(20070528) nightly build, but not the 1.5.0.10 build. I'm using XP Pro SP2, use the same profile for all three versions, and have both POP and IMAP accounts.


Reproducible: Always
Comment 1 Magnus Melin 2007-05-29 11:01:44 PDT
WFM for me on linux. Didn't test the sticky part, but at least the checkbox is obeyed.
Comment 2 RDL 2007-08-29 17:05:56 PDT
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3)
> Gecko/20070309 Firefox/2.0.0.3
> Build Identifier: version 2.0.0.4pre (20070528)
> 
> The "work offline" checkbox in the Thunderbird profile manager doesn't seem to
> have any effect when you launch Thunderbird from the profile manager.

I also to see this problem on TB 2.0.0.6 (20070728) under Win XP SP2

In Tools > Options > Advanced > Offline

I have 

When starting up:
(*) Remember previous online state
Send unsent messages when going online? (*) Ask me
Download messages for offline use when going offline? (*) No
Comment 3 Wayne Mery (:wsmwk, NI for questions) 2007-10-08 17:31:16 PDT
checkbox only worked for me with option "ask me". otherwise it wouldn't honor the profile override (or what I thought was an override). and even then it had the audacity to prompt me during startup with a default of "work online?"
v2.0.0.6 windows.

boy that was an irritating discovery.

duplicate?



Comment 4 David Mulej 2008-01-10 12:21:30 PST
I am using Thunderbird 2.0.0.9 with Windows Vista Home Premium.  When I open Thunderbird with the profile amanager, the work offline button has no effect.  In the recent past it worked, but not today.
Comment 5 Wayne Mery (:wsmwk, NI for questions) 2008-05-25 21:32:57 PDT
can you confirm?
Comment 6 Nikolay Shopik 2008-05-26 01:14:31 PDT
Works for me TB3a1, overriding works just fine.
Comment 7 Parkhideh 2008-07-08 14:19:37 PDT
Win 2000 with SP4; Thunderbird 2.0.0.14
The original report is correct.  In version 1.5 the check box worked.  
Now I get the irritating dialup window as soon as Thunderbird starts.

How do I get version 3 beta that is mentioned in comment #6 ?
 
Comment 8 Nikolay Shopik 2008-07-08 14:22:34 PDT
You can get these from here
http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
tb3a2 coming out soon too
Comment 9 Wayne Mery (:wsmwk, NI for questions) 2008-08-11 04:14:32 PDT
Eric, iirc you are not able to run trunk. Is that correct? 
Parkhideh, does version 3 work for you?

(offline is getting lots of attention on trunk, so it would be useful to know if trunk works for you)
Comment 10 Parkhideh 2008-08-11 14:52:16 PDT
(In reply to comment #9)
Wayne, comment #6 is correct.  Version 3.01a does honour the Work Offline checkbox.
Comment 11 Gary Kwong [:gkw] [:nth10sd] 2008-08-11 20:30:22 PDT
So this bug is fixed in Shredder 3.0 alpha / beta trunk builds, but not in 2.0.0.x?
Comment 12 Wayne Mery (:wsmwk, NI for questions) 2008-08-14 07:33:23 PDT
(In reply to comment #11)
> So this bug is fixed in Shredder 3.0 alpha / beta trunk builds, but not in
> 2.0.0.x?

apparently this and bug 382302 fixed on trunk - haven't found what fixed it. 
probably broken by bug 359134, which implements Bug 312793 and Bug 76111.

=> WFM.
If this is wanted in 2.0 someone will need to find what fixed it and nominate a patch to go into gecko 1.8/TB2.

Note You need to log in before you can comment on or make changes to this bug.