Closed Bug 382539 Opened 13 years ago Closed 12 years ago

ExtTextOutW failure when rendering text

Categories

(Core :: Graphics, defect, P2)

x86
Windows Vista
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: vlad, Assigned: pavlov)

References

()

Details

Attachments

(1 file, 1 obsolete file)

Clicking on the URL above (basically an input element with a large string inside it) causes debug spew:

_flush_glyphs: The operation completed successfully.
_cairo_win32_surface_show_glyphs(ExtTextOutW failed): The operation completed successfully.
(repeated)

and no text to get drawn inside the textbox.  Selecting text makes it appear.  This is in a 20070531 build.

In my build on 2007051405, the text does show up, but selecting text causes any text after the selection to not appear.
Flags: blocking1.9+
Attached patch v0.5 (obsolete) — Splinter Review
we want something like this.  there is some slight error in this patch and we could probably do this faster by merging all the loops together...
Attached patch v0.6Splinter Review
this is better but still has issues.. not sure what is going on....
Attachment #268430 - Attachment is obsolete: true
punting remaining a6 bugs to b1, all of these shipped in a5, so we're at least no worse off by doing so.
Target Milestone: mozilla1.9alpha6 → mozilla1.9beta1
Duplicate of this bug: 388156
I can't reproduce this in a debug build I made on Vista yesterday. Is there something I'm not doing right?
Hrm, I'm not seeing it right now on Vista; I'll check XP on monday.
Target Milestone: mozilla1.9 M8 → ---
Priority: -- → P2
this was fixed by 386895
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Flags: in-testsuite?
Flags: in-litmus?
Flags: in-testsuite?
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.