bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

url not correctly parsed from PEGASUS client

RESOLVED DUPLICATE of bug 5351

Status

Thunderbird
General
--
minor
RESOLVED DUPLICATE of bug 5351
11 years ago
11 years ago

People

(Reporter: riccardo carlesso, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: version 1.5.0.12 (20070509)

When a Pegasus email client sends a text url, it wraps lines in 78-chars chunks.
They are correctly rebuilt by pegasus itself AND by some webmails, like gmail.
Instead, my thunderbird client doesnt seem to understand that line wrap: it parses the first 80bytes of the URL until the first "\n" and when I click onto it, the browser opens the partial URL, ehich is not correct.
I'm not sure that PEGASUS behaviour is RFC-compliant. If it is, i think you should do something; if its not, I think you should change your code, but I encourage you to tell pegasus mantainer...

Reproducible: Always

Steps to Reproduce:
1. take a Pegasus email client and send a text email with a long url like: 
http://local.live.com/default.aspx?v=2&cp=q90xv34sy8hm&style=o&lvl=1&tilt=-90&dir=0&alt=-%201000&scene=1145528&encType=1


2. receive it with thunderbird
3. click on the url.
Actual Results:  
it goes onto the trunked url

Expected Results:  
follow the full url

Im sorry to bother you, this is a battle between thunderbird and pegasus.
I would like to understand who is right.
Can you please keep me informed if you correct the bug? or if you can prove me theer's no bug, can you tell me? please.

Thank you.

Comment 1

11 years ago
Can you attach such a mail (as received by thunderbird)? Save as .eml.
(Reporter)

Comment 2

11 years ago
Created attachment 267114 [details]
example of email that gets the url link 'cut in two'

this is the attachment you asked for

Comment 3

11 years ago
This should be bug 5351, without format=flowed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 5351
You need to log in before you can comment on or make changes to this bug.