Some accesskeys don't work in Options/Preferences dialog

RESOLVED FIXED in 1.0b1

Status

Calendar
Preferences
RESOLVED FIXED
11 years ago
8 years ago

People

(Reporter: Omar Bajraszewski, Unassigned)

Tracking

unspecified
1.0b1

Details

(Reporter)

Description

11 years ago
IN OPTIONS:
1)For Setting sound:
-"Odtwórz dźwięk"- ALT+o doesn't work
-"użyj domyślnego dźwieku"- ALT+d doesn't work
-"Odtwórz"-ALT+w doesn't work
2)For categories:
-"Dodaj" ALT+d doesn't work
3) For views:
- General "Pierwszy dzień tygodnia"- ALT+e doesn't work
-Work days "Wto" alt+w doesn't work, "Czw" ALT+C doesn't work
-Day view and week view "Dzień zaczyna się o", "Dzień kończy się o", "pokaż" ALT+z, ALT+k, ALT+o
-multiweek view "Domyślna liczba..." ALT_m doesn't work
-For last TAB (advanced settings) many others shortcuts doesn't work



version: Sunbird pl RC1
(Reporter)

Comment 1

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.4pre) Gecko/20070524 Sunbird/0.5

Updated

11 years ago
Assignee: nobody → marcoos+bmo
Blocks: 375873
Component: Sunbird Only → pl-PL / Polish
Product: Calendar → Mozilla Localizations
QA Contact: sunbird → adrian.kalla
Version: Sunbird 0.5 → unspecified
→ Hubert
Assignee: marcoos+bmo → hubert.gajewski
QA Contact: adrian.kalla → marcoos+bmo
Summary: PL-pl: Some shortcuts (access keys) doesn't work in options → [Sunbird] Some shortcuts (access keys) don't work in Options
Summary: [Sunbird] Some shortcuts (access keys) don't work in Options → [Sunbird] Some accesskeys don't work in Options

Comment 3

11 years ago
I think that it isn't a localization bug. I checked it and I don't see any duplicates in Options/Preferences window and in dtds. Clint, Stefan?

Comment 4

11 years ago
After discussion on IRC: Product -> Calendar
Assignee: hubert.gajewski → nobody
Component: pl-PL / Polish → General
Product: Mozilla Localizations → Calendar
QA Contact: marcoos+bmo → general

Updated

11 years ago
No longer blocks: 375873
Summary: [Sunbird] Some accesskeys don't work in Options → Some accesskeys don't work in Options
(Reporter)

Comment 5

11 years ago
I can see the same problem with Lightning 0.5 RC1. If it's not a localization issue I think it shouldn't block 0.5 release but IMHO a release note should be added to http://www.mozilla.org/projects/calendar/releases/common0.5.html

Comment 6

11 years ago
Cédric mentioned this before (e.g. Bug 348254 Comment #1) while he was working on the accesskeys: If the same accesskey is used on a completely different tab but in the same preference dialog they don't work.

The problem here is described in Bug 143065.

A workaround is that each accesskey must be used only once in the entire preference dialog including all tabs.

Comment 7

11 years ago
I don't think that this is serious enough to warrant a release note addition.

Comment 8

11 years ago
(In reply to comment #6)

> The problem here is described in Bug 143065.

You're right -> Resolved Duplicate.

> A workaround is that each accesskey must be used only once in the entire
> preference dialog including all tabs.

Not in Sunbird's Preferences/Options window with the Latin alphabet - we are over 40 accesskeys here.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 143065

Comment 9

11 years ago
It wasn't a good idea, sorry. I'm reopening and adding a dependency.
Status: RESOLVED → REOPENED
Depends on: 143065
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
Component: General → Preferences
OS: Windows XP → All
QA Contact: general → preferences
Hardware: PC → All

Updated

11 years ago
Summary: Some accesskeys don't work in Options → Some accesskeys don't work in Options/Preferences dialog

Updated

10 years ago
Duplicate of this bug: 389249

Comment 11

10 years ago
Adding the term accelerator key so it shows up in Bugzilla searches - sorry for the earlier dupe (Bug 389249).
(In reply to comment #0)
> IN OPTIONS:
> 1)For Setting sound:
> -"Odtwórz dźwięk"- ALT+o doesn't work
> -"użyj domyślnego dźwieku"- ALT+d doesn't work
> -"Odtwórz"-ALT+w doesn't work
> 2)For categories:
> -"Dodaj" ALT+d doesn't work
> 3) For views:
> - General "Pierwszy dzień tygodnia"- ALT+e doesn't work
> -Work days "Wto" alt+w doesn't work, "Czw" ALT+C doesn't work
> -Day view and week view "Dzień zaczyna się o", "Dzień kończy się o",
> "pokaż" ALT+z, ALT+k, ALT+o
> -multiweek view "Domyślna liczba..." ALT_m doesn't work
> -For last TAB (advanced settings) many others shortcuts doesn't work
> 
> 
> 
> version: Sunbird pl RC1
> 

(In reply to comment #0)
> IN OPTIONS:
> 1)For Setting sound:
> -"Odtwórz dźwięk"- ALT+o doesn't work
> -"użyj domyślnego dźwieku"- ALT+d doesn't work
> -"Odtwórz"-ALT+w doesn't work
> 2)For categories:
> -"Dodaj" ALT+d doesn't work
> 3) For views:
> - General "Pierwszy dzień tygodnia"- ALT+e doesn't work
> -Work days "Wto" alt+w doesn't work, "Czw" ALT+C doesn't work
> -Day view and week view "Dzień zaczyna się o", "Dzień kończy się o",
> "pokaż" ALT+z, ALT+k, ALT+o
> -multiweek view "Domyślna liczba..." ALT_m doesn't work
> -For last TAB (advanced settings) many others shortcuts doesn't work
> 
> 
> 
> version: Sunbird pl RC1
> 

Looking at it with 0.9pre from CVS with et translation (not in repo yet) everything mentioned in comment #0 except advanced settings tab seems to work. I checked that advanced.dtd has unique keys and even with unique keys most of the keys there don't work. Could anyone confirm that?

Comment 13

9 years ago
This will be an issue unless Sunbird switches to Trunk where Bug 143065 is fixed. In 0.9pre builds access keys must be unique across all preference panels and tabs to work - an almost impossible task.

Comment 14

9 years ago
Fixed on trunk. I cannot fix this issue on Sunbird 0.9 - more accesskeys than letters in the alphabet :-)
Status: NEW → RESOLVED
Last Resolved: 11 years ago9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.