Mail folder is empty though messages exist in the associated mbox file

RESOLVED DUPLICATE of bug 379101

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 379101
11 years ago
8 years ago

People

(Reporter: Thomas Keller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; de-de) AppleWebKit/419 (KHTML, like Gecko) Safari/419.3
Build Identifier: Version 2.0.0.0 (20070326)

My wife has a thunderbird setup and recently noticed that some of her mails "vanished" from some of their folders. She has no filters et al applied to any of these folders where this happens, still she cannot see any emails in them. The error console doesn't show anything. Looking in the file system for one of this folders, the associated files and folder are there:

$ cd ~/Library/Thunderbird/Profiles/iq8yxwsu.default/Mail/Local\ Folders\Freunde.sbd
$ $ ls  -la Katja\ M.*
-rw-------   1 marlen  admin  8047361 Dec 24 09:29 Katja M.
-rw-r--r--   1 marlen  admin    11675 Apr 13 13:19 Katja M..msf

Katja M..sbd:
total 0
drwxr-xr-x    2 marlen  admin    68 Sep  5  2006 .
drwxr-xr-x   35 marlen  admin  1190 Jun  2 23:14 ..

I deleted all .msf index files in this folder (as I remember that there are sometimes problems with mail display with the mbox format and these usually go away if one removes the index files by hand and lets Thunderbird re-create them) and restarted Thunderbird.

Suddenly a completly new mbox and index file was created in the filesystem, without any further action: 

-rw-r--r--    1 marlen  admin        0B Jun  2 23:46 Katja Mf8b8aab7
-rw-r--r--    1 marlen  admin        1K Jun  2 23:46 Katja Mf8b8aab7.msf

The mails in the original folder are still not shown, however. If Thunderbird is restarted another time, the newly created (empty) "Katja Mf8b8aab7" mbox is shown in Thunderbirds tree pane as another instance of the "Katja M." folder (apparently it uses the same naming) and is empty as well.

So I'm basically having two problems here:

a) Thunderbird mail folders which tend to duplicate themselves with suspicious new mbox files
b) Still no mail display for the original (faulty) folders

Sorry if this is a dupe of something else, but I was completly unable to give proper keywords for a dupe search.

Thanks in advance for your support.

Thomas.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(In reply to comment #0)
> -rw-------   1 marlen  admin  8047361 Dec 24 09:29 Katja M.
> -rw-r--r--   1 marlen  admin    11675 Apr 13 13:19 Katja M..msf

> -rw-r--r--    1 marlen  admin        0B Jun  2 23:46 Katja Mf8b8aab7
> -rw-r--r--    1 marlen  admin        1K Jun  2 23:46 Katja Mf8b8aab7.msf

DUP of Bug 379101.

(Recovery procedure)
1. Rename "Katja M."/"Katja M..msf"/"Katja M..sbd" (say Backup)
2. Delete Mf8b8aab7/Mf8b8aab7.msf (current mail folder files for "Katja M.")
3. Restart Thunderbird => Mail folder of "Backup" will appear.
You can change folder name "Katja M." again now, but please note that file name of "Katja Mf8b8aab7" is used(by current design). 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 379101
You need to log in before you can comment on or make changes to this bug.