The default bug view has changed. See this FAQ.

Back-port several nsWindow fixes to branch

RESOLVED FIXED in mozilla1.8.1

Status

Core Graveyard
Widget: BeOS
RESOLVED FIXED
10 years ago
2 years ago

People

(Reporter: Doug Shelton, Assigned: Doug Shelton)

Tracking

({fixed1.8.1.5})

unspecified
mozilla1.8.1
x86
BeOS
fixed1.8.1.5
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs testcase])

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
User-Agent:       Mozilla/5.0 (BeOS; U; BeOS BePC; en-US; rv:1.8.1.5pre) Gecko/20070603 BonEcho/2.0.0.5pre
Build Identifier: 

To improve reliability, we'd like to backport the changes from bug 296856, 319881 and 312070 to the Firfox 2.0 branch.  Only files in mozilla/widget/src/beos are changed.  These changes improve performance and add support for floating and modal windows.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Assignee)

Comment 1

10 years ago
Created attachment 267067 [details] [diff] [review]
unified patch for backporting

This patch was created after backporting the three bugs mentioned.  I could also create a separate patch and apply to each bug setting appropriate dependencies.  This is just a quick and easy way to get the code in for review.
Attachment #267067 - Flags: review?(sergei_d)
(Assignee)

Updated

10 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

10 years ago
Depends on: 296856, 312070, 319881
Target Milestone: --- → mozilla1.8.1

Comment 2

10 years ago
I think that build with back-ported patch need some public testing too.
Before further steps.

Comment 3

10 years ago
Bug 312070 is probably a wrong bug number... (has nothing to do with BeOS)
(Assignee)

Comment 4

10 years ago
(In reply to comment #3)
> Bug 312070 is probably a wrong bug number... (has nothing to do with BeOS)
> 
Dyslexic fat-fingering strikes again.  Correct dependency is bug 321070.
Depends on: 321070
No longer depends on: 312070
(Assignee)

Comment 5

10 years ago
(In reply to comment #3)
> Bug 312070 is probably a wrong bug number... (has nothing to do with BeOS)
> 
Dyslexic fat-fingering strikes again.  Correct dependency is bug 321070.
(Assignee)

Comment 6

10 years ago
Comment on attachment 267067 [details] [diff] [review]
unified patch for backporting

frederick, please review if you have time.
Attachment #267067 - Flags: review?(sergei_d) → review?(thesuckiestemail)

Comment 7

10 years ago
Comment on attachment 267067 [details] [diff] [review]
unified patch for backporting

changing attachment to patch
Attachment #267067 - Attachment is patch: true
Attachment #267067 - Attachment mime type: application/octet-stream → text/plain

Comment 8

10 years ago
Comment on attachment 267067 [details] [diff] [review]
unified patch for backporting

r=thesuckiestemail@yahoo.se
Looks ok to me
Attachment #267067 - Flags: review?(thesuckiestemail) → review+
(Assignee)

Comment 9

10 years ago
gavin, since all changes are in beos code, is there any reason why we cannot update the branch with this code?
Assignee: nobody → doug
Status: ASSIGNED → NEW
No, there shouldn't be anything preventing this from landing on the branch. You do still need to request approval, however, unless you have a prior agreement with the 1.8[.0] branch drivers.
(Assignee)

Updated

10 years ago
Flags: blocking1.8.1.5?
You want to request approval1.8.1.5 on the attachment, not blocking1.8.1.5 on the bug - it's pretty unlikely that a BeOS bug is going to be blocking a branch release :).
(Assignee)

Comment 12

10 years ago
(In reply to comment #11)
> You want to request approval1.8.1.5 on the attachment, not blocking1.8.1.5 on
> the bug - it's pretty unlikely that a BeOS bug is going to be blocking a branch
> release :).
> 
(what's the emoticon for embarrassment?)  Very true.  How does one request approval?  I thought it might be requested via the "wanted 1.8.1.x" dropdown, but this dropdown is greyed out and non-functional here.
Flags: blocking1.8.1.5?
(Assignee)

Updated

10 years ago
Attachment #267067 - Flags: approval1.8.1.5?
(Assignee)

Comment 13

10 years ago
(insert embarrassment icon again).  Just found the request on the attachment page.  "RTFM" even with comments.
Comment on attachment 267067 [details] [diff] [review]
unified patch for backporting

approved for 1.8.1.5, a=dveditz for release-drivers
Attachment #267067 - Flags: approval1.8.1.5? → approval1.8.1.5+

Comment 15

10 years ago
cvs commit: Examining mozilla/widget/src/beos
Enter passphrase for key '/boot/home/.ssh/id_dsa':
Checking in mozilla/widget/src/beos/nsAppShell.cpp;
/cvsroot/mozilla/widget/src/beos/nsAppShell.cpp,v  <--  nsAppShell.cpp
new revision: 1.29.8.2; previous revision: 1.29.8.1
done
Checking in mozilla/widget/src/beos/nsAppShell.h;
/cvsroot/mozilla/widget/src/beos/nsAppShell.h,v  <--  nsAppShell.h
new revision: 1.10.28.2; previous revision: 1.10.28.1
done
Checking in mozilla/widget/src/beos/nsDragService.cpp;
/cvsroot/mozilla/widget/src/beos/nsDragService.cpp,v  <--  nsDragService.cpp
new revision: 1.13.28.4; previous revision: 1.13.28.3
done
Checking in mozilla/widget/src/beos/nsDragService.h;
/cvsroot/mozilla/widget/src/beos/nsDragService.h,v  <--  nsDragService.h
new revision: 1.4.28.3; previous revision: 1.4.28.2
done
Checking in mozilla/widget/src/beos/nsSwitchToUIThread.h;
/cvsroot/mozilla/widget/src/beos/nsSwitchToUIThread.h,v  <--  nsSwitchToUIThread.h
new revision: 1.4.28.1; previous revision: 1.4
done
Checking in mozilla/widget/src/beos/nsToolkit.cpp;
/cvsroot/mozilla/widget/src/beos/nsToolkit.cpp,v  <--  nsToolkit.cpp
new revision: 1.23.8.1; previous revision: 1.23
done
Checking in mozilla/widget/src/beos/nsToolkit.h;
/cvsroot/mozilla/widget/src/beos/nsToolkit.h,v  <--  nsToolkit.h
new revision: 1.5.8.1; previous revision: 1.5
done
Checking in mozilla/widget/src/beos/nsWindow.cpp;
/cvsroot/mozilla/widget/src/beos/nsWindow.cpp,v  <--  nsWindow.cpp
new revision: 1.91.4.26; previous revision: 1.91.4.25
done
Checking in mozilla/widget/src/beos/nsWindow.h;
/cvsroot/mozilla/widget/src/beos/nsWindow.h,v  <--  nsWindow.h
new revision: 1.35.4.15; previous revision: 1.35.4.14
done 

Comment 16

10 years ago
probably something like FIXED1.5 should be added to "keywords".
right?
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed1.8.1.5
Resolution: --- → FIXED
Whiteboard: [needs testcase]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.