need to update fonts when prefs change

VERIFIED FIXED in M16

Status

()

Core
Layout
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Erik van der Poel, Assigned: Simon Fraser)

Tracking

({pp})

Trunk
PowerPC
Mac System 8.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

18 years ago
When the user changes the fonts in the prefs panel, Mozilla should update the
fonts accordingly, but Mac gfx doesn't, yet.

Frank, I don't know if there will be a timing problem. The layout engine already
has a pref callback for the fonts, and it asks the device context to delete all
of them before reflowing all documents. If this happens before you do whatever
is needed in Mac gfx, then there may be a problem. (This problem does not occur
on Windows and Unix since the pref-sensitive data is stored in nsIFontMetrics
objects, which are deleted ("Flush").) Please keep this in mind when you work
on this.

Comment 1

18 years ago
I think this should be nsbeta2.
Status: NEW → ASSIGNED
Keywords: nsbeta2
Target Milestone: --- → M17

Comment 2

18 years ago
move to M16
OS: Mac System 7 → Mac System 8.0
Target Milestone: M17 → M16

Comment 3

18 years ago
Putting on [nsbeta2+] radar for beta2 fix.
Whiteboard: [nsbeta2+]

Comment 4

18 years ago
Running the daily build from Friday on the Mac, the problem seems to be that the 
Mac IGNORES COMPLETELY the font prefs. You can set whatever you want, quit, 
relaunch, verify that the prefs are still set but the text stays in Times/
Helvetica. The font size setting works though...

Comment 5

18 years ago
Partially fix the problem. Now the turkish / baltic font pref setting won't 
overrule the smRoman font pref. We will rebuild the mapping util singleton when 
the font pref changed. However, there are still problem. It is hard to fix now 
since the preference window is pretty bad now. After I open pref window and OK, 
the second time I open the prefwindow will cause problem and need quit.

Comment 6

18 years ago
Part of this problem on the Mac side may be related to the dpi pref.  

When I changed the value on the font preference window from 96 to 72 dpi (to 
better fit the Mac), the problem seemed to get worse.  M15 did not seem to like 
it, as did today's daily Mac build (2000051908).

The daily Mac build from today -- 2000051908 -- seemed much more unstable on an 
iMac DV.  It wouldn't run for more than a couple minutes before crashing.  FWIW, 
I'll check this again when a more stable M16 comes out.

Oh, yes.  Mac OS 9.0.4, MRJ 2.2, carbon libs 1.0.4, Apple multimedia update 1.0 
installed.

Comment 7

18 years ago
reassign to garywade@desisoftsystems.com
Assignee: ftang → garywade
Status: ASSIGNED → NEW

Updated

18 years ago
Blocks: 24343
*** Bug 40219 has been marked as a duplicate of this bug. ***
spam: adding pp kw, adding self to cc list.
Keywords: pp

Comment 10

18 years ago
reassign sfraser.
sfraser- if this a dup of your fix yesterday, please mark it fixed. Otherwise, 
reassign this back to  garywade@desisoftsystems.com
Assignee: garywade → sfraser
(Assignee)

Comment 11

18 years ago
This seems to work now.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 12

18 years ago
Fixed in the June 6th Mac build (2000060608).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.