discard bind and Function.prototype.bind in favor of BindToObject

RESOLVED FIXED in Firefox 3 alpha6

Status

()

Toolkit
Safe Browsing
--
minor
RESOLVED FIXED
11 years ago
4 years ago

People

(Reporter: Simon Bünzli, Assigned: Simon Bünzli)

Tracking

Trunk
Firefox 3 alpha6
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

11 years ago
... which is used everywhere opposed to the first two which are both called exactly from one place: BindToObject.
(Assignee)

Comment 1

11 years ago
Created attachment 267217 [details] [diff] [review]
fix
Assignee: nobody → zeniko
Status: NEW → ASSIGNED
Attachment #267217 - Flags: review?(tony)

Comment 2

11 years ago
Comment on attachment 267217 [details] [diff] [review]
fix

>Index: lang.js
>+ * @param opt_{...} Dummy optional arguments to make a jscompiler happy
>+function BindToObject(fn, self, opt_A, opt_B, opt_C, opt_D, opt_E, opt_F) {

Nit: We should just remove the opt_* args since the jscompiler that's referred to here is a Google specific tool.
Attachment #267217 - Flags: review?(tony) → review+

Comment 3

11 years ago
I'm not going to submit this until bug 383269 is resolved for fear of making the test case un-reproducible.
Depends on: 383269
(Assignee)

Comment 4

11 years ago
Created attachment 267932 [details] [diff] [review]
fix (with only minimal opt_* arguments)
Attachment #267217 - Attachment is obsolete: true
(Assignee)

Updated

11 years ago
Whiteboard: [checkin needed (once bug 383269 is fixed)]
Target Milestone: --- → Firefox 3 alpha6
Version: unspecified → Trunk
(Assignee)

Updated

11 years ago
Whiteboard: [checkin needed (once bug 383269 is fixed)] → [checkin needed]

Comment 5

11 years ago
Checked in "fix (with only minimal opt_* arguments)". Clearing checkin-needed status.
Whiteboard: [checkin needed]
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Flags: in-testsuite-
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.